Project

General

Profile

Actions

Defect #39150

closed

right-click menu not always appearing in large lists

Added by Thomas B 5 months ago. Updated 11 days ago.

Status:
Closed
Priority:
Normal
Category:
UI
Target version:
-
Start date:
Due date:
% Done:

0%

Estimated time:
Resolution:
Invalid
Affected version:

Description

When looking at the issues overview of a project, right clicking on an item's "cell" instead of the text with hyperlink, a context-menu appears when there arent that many items. With full pages (50 items) sometimes the menu appears way lower than the mouse pointer and sometimes not at all (maybe its just off-screen?).
I tested using the default theme.

Is this a known-issue and how can i resolve it ?

The version is Redmine 5.0.5-stable but for some reason i can only pick 5.0.4 or 5.0.6 in the drop-down menu below this ticket to select the affected version

Best regards,


Files

devtools.jpg (37.9 KB) devtools.jpg Thomas B, 2024-01-23 13:55
nok1.png (86.9 KB) nok1.png halfway or bottome of table click upper rows is not ok Thomas B, 2024-01-23 14:02
nok2.png (87 KB) nok2.png halfway or bottome of table click lower rows is not ok Thomas B, 2024-01-23 14:02
ok1.png (78.8 KB) ok1.png top of table click upper rows is ok Thomas B, 2024-01-23 14:02
ok2.png (80.4 KB) ok2.png top of table click lower rows is ok Thomas B, 2024-01-23 14:02
Actions #1

Updated by Mischa The Evil 4 months ago

  • Affected version changed from 5.0.4 to 5.0.5
Actions #2

Updated by Thomas B about 1 month ago

Hi,any updates here ? This is still an issue. I found many threads related but these are from 16 years ago and the code had changed

Actions #3

Updated by Holger Just about 1 month ago

  • Status changed from New to Needs feedback

Could you please confirm your browser and its version? Also, please make sure to disable any browser extensions such as ad blockers or virus scanners within your browser. If the issue still occurs, it would be helpful to show a video (or at least a screenshot) of the issue.

Please also check your browser's JavaScript console in its developer console for any errors or warnings and also provide those here..

Actions #4

Updated by Thomas B about 1 month ago

Holger Just wrote in #note-3:

Could you please confirm your browser and its version? Also, please make sure to disable any browser extensions such as ad blockers or virus scanners within your browser. If the issue still occurs, it would be helpful to show a video (or at least a screenshot) of the issue.

Please also check your browser's JavaScript console in its developer console for any errors or warnings and also provide those here..

Hi,

thank you for you quick response. The browser used is Microsoft Edge v 120.0.2210.121 (official build) (64-bit).
The only error in the dev tools console is
"Uncaught ReferenceError: setSelect2Filter is not defined" (see attached screenshot). (This shows up on every page)

I created a clip but its too large to attach.. i made some screenshots instead.
Basically what happens is when the scrollbar is at the top so the overview doesn't fill the entire screen, it works. Whether i click on the top rows or bottom.
When i click the bottom row, the menu will position its bottom side on the same height (y-axis coordinate) of the mouse pointer so it stays on screen and doesnt get cut off.

When i scroll down, anytime I click somewhere on the top or bottom the menu will be offset with half a screen (towards the bottom)so when i click on the lower rows, the menu isnt visible at all because its rendered off screen.

also my context_menu.js and context_menu.css aren't changed from the original redmine 5.0.5

in screenshot ok1 i clicked on the top row (hightlighted in blue) and the menu appears on that same position. (ignore the mouse pointers position)
in ok2 i clicked on the bottom row, also good.

in nok1 after scrolling down i clicked on the top row and the menu appears on the bottom.
in nok2 i clickedo n the lower row after scrolling down and the menu is cut off

Actions #5

Updated by Marius BĂLTEANU 28 days ago

setSelect2Filter is not part of Redmine core, is added by one of your plugins, I assume to replace some standard select fields with Select2 autocomplete. From what I know, select2 is quite heavy and it could be the source of your problem.

My advise is to try without that specific plugin or all plugins to see if the issue still reproduces. If the issue doesn't reproduce, you can report the problem to the plugin author.

Actions #6

Updated by Thomas B 11 days ago

Marius BĂLTEANU wrote in #note-5:

setSelect2Filter is not part of Redmine core, is added by one of your plugins, I assume to replace some standard select fields with Select2 autocomplete. From what I know, select2 is quite heavy and it could be the source of your problem.

My advise is to try without that specific plugin or all plugins to see if the issue still reproduces. If the issue doesn't reproduce, you can report the problem to the plugin author.

thanks for your response
turned out that error was a red herring. it was a plugin (redmine_hide_sidebar) that introduced the problem.

Actions #7

Updated by Marius BĂLTEANU 11 days ago

  • Status changed from Needs feedback to Closed
  • Assignee set to Marius BĂLTEANU
  • Resolution set to Invalid

Thanks for coming back with a feedback!

Actions

Also available in: Atom PDF