Feature #4968

REST API new features

Added by Javier Hernandez over 9 years ago. Updated over 7 years ago.

Status:ClosedStart date:2010-03-02
Priority:NormalDue date:
Assignee:-% Done:

0%

Category:REST API
Target version:-
Resolution:Duplicate

Description

Hi, i'm developing a redmine's desktop client, but i need some features in REST API.

I enumerate features that i need, at this moment, for continue with the project:

  • Time tracking: Add spent-hours to issues
  • Projects-related features
    • Members in a project, for assign issues to a specific member
  • Issues-related features
    • Get Issues' possible types
    • Get Issues' possible categories
    • Add notes to journals at issue's update
    • Attachment files, at creation and at issue's update

Now, my application can get and create/update/delete issues/projects, but options are a little bit limited.

It is difficult to implement this?

Thanks in advance!


Related issues

Related to Redmine - Feature #7420: Rest API for projects members Closed 2011-01-24
Related to Redmine - Feature #8171: Adding attachments through the REST API Closed 2011-04-17
Duplicates Redmine - Feature #296: REST API Closed

History

#1 Updated by Nikolay Kotlyarov over 9 years ago

Javier Hernandez wrote:

i'm developing a redmine's desktop client, but i need some features in REST API

Could you share the client when it'll be done?:)

#2 Updated by Javier Hernandez over 9 years ago

Nikolay Kotlyarov wrote:

Javier Hernandez wrote:

i'm developing a redmine's desktop client, but i need some features in REST API

Could you share the client when it'll be done?:)

Of course, in fact, the project is created in launchpad, but still without code because current version is very alpha.

http://launchpad.net/pyredmine

#3 Updated by Felix Schäfer over 9 years ago

  • Status changed from New to Closed
  • Resolution set to Duplicate

There is already a (long-ish) feature request for a REST API at #296, please post your suggestions/ideas there to keep it all in one place.

#4 Updated by Yohann Monnier about 9 years ago

Test this version here

http://github.com/Yohannsmonnier/redmine

Its allow :

  • List members of a projet
  • Timelog API
  • Get trackers
  • Get all priorities
  • Get allowed state when editing an issue
  • it also Corrects generated REST XMLs

#5 Updated by Javier Hernandez about 9 years ago

Hi Yohann!

I greatly appreciate your attention, i had temporaly stopped the project and now I think I'll be able to publish something functional. I hope to have a look this weekend to your branch and make some tests with it.

Regards!

#6 Updated by Bevan Rudge about 8 years ago

Yohann; What is the status of your Redmine fork on GitHub? Are you merging Redmine's changes into your fork? Have your changes been contributed back to Redmine? Will they? Are you still contributing to the Redmine project? Thanks for the update!

Related; http://www.redmine.org/issues/7420

#7 Updated by Bevan Rudge about 8 years ago

  • Status changed from Closed to Reopened

I am reopening since #296 is done and dusted, but these features did not get in yet.

This is related or duplicate of #7180 and/or #7402.

It would be great to get this or one of those reviewed and committed.

#8 Updated by Bevan Rudge about 8 years ago

I meant #7819, not #7402.

#9 Updated by Bevan Rudge almost 8 years ago

Also related: #8745

#10 Updated by Etienne Massip almost 8 years ago

  • Assignee deleted (Eric Davis)

#11 Updated by Jean-Philippe Lang over 7 years ago

  • Status changed from Reopened to Closed

I'm closing this since everything in now present in the API, except for the attachments. But there's a more specific ticket for that (#8171).

Also available in: Atom PDF