Project

General

Profile

Actions

Defect #6256

closed

Redmine considers non ASCII and UTF-16 text files as binary in SCM

Added by Victor Gavro almost 14 years ago. Updated about 7 years ago.

Status:
Closed
Priority:
Low
Assignee:
Toshi MARUYAMA
Category:
SCM
Target version:
Start date:
2010-08-31
Due date:
% Done:

0%

Estimated time:
Resolution:
Fixed
Affected version:

Description

If source file contains less than 30% of ascii symbols - redmine threats it as binary.
It's affected when browsing repository:
/projects/PROJECT/repository/entry/FILE
(redmine just starts downloading, not showing source file).
The problem is that redmine relies on string method http://apidock.com/ruby/String/is_binary_data%3F
I understand this is ruby problem, but redmine could do some more checks - at least check for BOM marks.

more information here:
when trying to open files in repository,but downloading s...


Related issues

Related to Redmine - Patch #6416: When viewing utf-8 text file in repository, it is downloadedClosed2010-09-16

Actions
Related to Redmine - Feature #4477: Use mime types in downloading from repositoryClosed2009-12-23

Actions
Related to Redmine - Feature #2209: MIME type support for repository EntriesClosed2008-11-17

Actions
Related to Redmine - Patch #3770: text/html documents force currently firefox to open download dialogClosed2009-08-23

Actions
Related to Redmine - Feature #6374: File raw view modeClosedToshi MARUYAMA2010-09-12

Actions
Has duplicate Redmine - Defect #7134: is_binary_data uses wrong heuristic to decide if a string is binaryClosed2010-12-19

Actions
Actions

Also available in: Atom PDF