Feature #6889

Set assignee on category change

Added by Peng Wang about 11 years ago. Updated about 6 years ago.

Status:NewStart date:2010-11-15
Priority:NormalDue date:
Assignee:-% Done:

0%

Category:Issues
Target version:-
Resolution:

Description

To reproduce:
1. File a new issue (leave the issue category empty)
2. update the issue and select an issue category

It is expected to see the assignee field to be changed automatically with the one specified in issue category. But it turns out that the assignee remains empty.


Related issues

Related to Redmine - Defect #23394: Auto-assign on category selection does not work when assi... New
Duplicated by Redmine - Defect #18393: issue assigning does not work when users change issue "Ca... Closed
Duplicated by Redmine - Feature #12214: Category change should cause assignee change Closed
Duplicated by Redmine - Defect #20429: Tracker with assignee field disabled, Is getting assigned... Closed

History

#1 Updated by Jean-Philippe Lang about 11 years ago

  • Tracker changed from Defect to Feature
  • Subject changed from Update issue category will not get assignee updated to Set assignee on category change

Actually, the current behaviour is to set the assignee automatically on issue creation only, as requested in #382. This is also described in the guide.

#2 Updated by Peng Wang about 11 years ago

Thanks for the reply, and it would be nice if we can add the feature because the testers sometimes forgot to select the category and will try to update it later, but developers got no email notification.

#3 Updated by Mischa The Evil about 7 years ago

  • Duplicated by Defect #18393: issue assigning does not work when users change issue "Category" added

#4 Updated by Mischa The Evil about 7 years ago

  • Duplicated by Feature #12214: Category change should cause assignee change added

#5 Updated by Toshi MARUYAMA about 6 years ago

  • Related to Defect #20429: Tracker with assignee field disabled, Is getting assigned with Assignee through Category added

#6 Updated by Toshi MARUYAMA about 6 years ago

  • Related to deleted (Defect #20429: Tracker with assignee field disabled, Is getting assigned with Assignee through Category)

#7 Updated by Toshi MARUYAMA about 6 years ago

  • Duplicated by Defect #20429: Tracker with assignee field disabled, Is getting assigned with Assignee through Category added

#8 Updated by Toshi MARUYAMA about 6 years ago

#20429 says if assignee field is disabled, no change of assignee in issue updating is confusing.

#9 Updated by Toshi MARUYAMA over 5 years ago

  • Related to Defect #23394: Auto-assign on category selection does not work when assignee is a required field added

Also available in: Atom PDF