Defect #7138

Unable to create new users

Added by James Turnbull over 8 years ago. Updated over 8 years ago.

Status:ClosedStart date:2010-12-20
Priority:UrgentDue date:
Assignee:-% Done:

0%

Category:Accounts / authentication
Target version:-
Resolution: Affected version:

Description

We upgraded to 1.0.4 HEAD to address some security issues and now get:

Email notifications is not included in the list

When new users try to create accounts.

History

#1 Updated by Jean-Baptiste Barth over 8 years ago

Before we investigate, can you give us the output of a ruby script/about ? Did you run the migrations correctly before it occurred ?

#2 Updated by James Turnbull over 8 years ago

I ran the migration.

About your application's environment
Ruby version              1.8.7 (x86_64-linux)
RubyGems version          1.3.5
Rack version              1.0
Rails version             2.3.5
Active Record version     2.3.5
Active Resource version   2.3.5
Action Mailer version     2.3.5
Active Support version    2.3.5
Application root          /opt/projects.puppetlabs.com
Environment               production
Database adapter          mysql
Database schema version   20100819172912

About your Redmine plugins
Redmine Vote plugin                     0.0.2
Redmine Simple Support                  0.1.0
Bots filter                             1.02
Redmine Hide Emails By Default plugin   0.0.1
Redmine puppetlabs helper               
Markdown formatter                      0.0.1
Redmine Hudson plugin                   1.0.1.1
Redmine Contributor Licensing           0.1.0
Redmine Extra Recipients                0.1.0
Redmine Changelogs plugin               0.1.1
Google Analytics plugin                 0.1.0

#3 Updated by James Turnbull over 8 years ago

  • Status changed from New to Resolved

Okay - I ran the migrations one more. No dice. Ran it a third time. Now works. And schema is updated.

I have no idea why...

#4 Updated by Jean-Baptiste Barth over 8 years ago

  • Status changed from Resolved to Closed

Weird. I'd be curious to see the console outputs if you already have it.

#5 Updated by Jean-Philippe Lang over 8 years ago

I don't think it's a database migration issue. I'm pretty sure that the app was not properly restarted.

#6 Updated by James Turnbull over 8 years ago

JPL - my sequence was:

1. Deploy new code.
2. Run migration
3. Restart unicorn and Apache.
4. Unable to create user.

Then:

1. Restart unicorn and Apache.
2. Problem still exists

Then:

1. Re-run migration.
2. Restart app.

Finally I ran the migration a third-time and it made the required changes and I restarted and it worked. The first two times it seemed like it didn't pick up the migrations?

Also available in: Atom PDF