Feature #7364

Make closed issues in archived projects still accessible read only

Added by Jeff Dillon about 9 years ago. Updated almost 5 years ago.

Status:ClosedStart date:2011-01-18
Priority:NormalDue date:
Assignee:-% Done:

0%

Category:Issues
Target version:-
Resolution:

Description

We reference issue numbers in our src control systems and in other areas. When an issue gets closed and project layouts get moved around, closed issues end up in dead projects that are archived.

The problem is that when you access the link of a dead issue, it's not found with a permission error.

Make it so that the issue can be accessed read only, even if the project is archived.


Related issues

Related to Redmine - Feature #3640: Freeze / Close Projects Closed 2009-07-20

History

#1 Updated by Etienne Massip about 9 years ago

  • Category set to Issues

#2 Updated by David Lyons almost 9 years ago

This is pretty annoying for us as well, there is a lot of knowledge in the old tickets that is not available simply because redmine is blocking access to the archived projects tickets. It seems silly that the search is incapable of finding archived tickets.

#3 Updated by Alex Dergachev over 7 years ago

This might be duplicate of http://www.redmine.org/issues/6049

#4 Updated by Go MAEDA almost 5 years ago

  • Status changed from New to Closed

With "Close projects" feature added by #3640 (Redmine 2.1.0), you can make projects read only.

#5 Updated by Go MAEDA almost 5 years ago

Also available in: Atom PDF