Project

General

Profile

Actions

Defect #7969

closed

Redmine dosn't work with sqlite3-ruby 1.3.3

Added by Daniel Bond about 13 years ago. Updated about 9 years ago.

Status:
Closed
Priority:
Normal
Assignee:
-
Category:
Database
Target version:
-
Start date:
2011-03-23
Due date:
% Done:

0%

Estimated time:
Resolution:
Cant reproduce
Affected version:

Description

I'm moving redmine (1.0.1) to a new server (ruby 1.8.7), when I installed sqlite3-ruby 1.3.3 on the new machine, redmine dosn't work correctly:

ArgumentError (comparison of Time with String failed):
app/models/setting.rb:152:in `<='
app/models/setting.rb:152:in `check_cache'
app/controllers/application_controller.rb:55:in `user_setup'
/usr/lib/ruby/1.8/webrick/httpserver.rb:104:in `service'
/usr/lib/ruby/1.8/webrick/httpserver.rb:65:in `run'
/usr/lib/ruby/1.8/webrick/server.rb:173:in `start_thread'
/usr/lib/ruby/1.8/webrick/server.rb:162:in `start'
/usr/lib/ruby/1.8/webrick/server.rb:162:in `start_thread'
/usr/lib/ruby/1.8/webrick/server.rb:95:in `start'
/usr/lib/ruby/1.8/webrick/server.rb:92:in `each'
/usr/lib/ruby/1.8/webrick/server.rb:92:in `start'
/usr/lib/ruby/1.8/webrick/server.rb:23:in `start'
/usr/lib/ruby/1.8/webrick/server.rb:82:in `start'

the problem occurs because with sqlite3-ruby 1.3.3, "settings_updated_on = Setting.maximum(:updated_on)" is a String.

I installed sqlite3-ruby 1.2.4 and it worked fine again.

If this is a issue with sqlite3-ruby rather than redmine, I'd not be surprised, but I would imagine other users might face the same issue, and in that case might be worth noting somewhere.


Related issues

Related to Redmine - Feature #5638: Use Bundler (Gemfile) for gem managementClosedJean-Philippe Lang2010-06-02

Actions
Has duplicate Redmine - Defect #10506: Internal error after reinstalling redminClosed

Actions
Actions #1

Updated by Etienne Massip about 13 years ago

  • Category set to Database
Actions #2

Updated by Jean-Philippe Lang about 13 years ago

  • Resolution set to Cant reproduce

I actually run tests with sqlite3 1.3.3 x86-mingw32 and don't have this issue.

>> Setting.maximum(:updated_on)
=> Sun Apr 03 18:25:29 +0200 2011
>> Setting.maximum(:updated_on).class
=> Time
Actions #3

Updated by Yuya Nishihara almost 13 years ago

the problem occurs because with sqlite3-ruby 1.3.3, "settings_updated_on = Setting.maximum(:updated_on)" is a String.

Do you have some incompatible plugins installed, by any chance? In my case, stuff_to_do_plugin produces this problem.

Try rake db:schema:dump to see if db/schema.rb gets broken. If it contains "Could not dump table ... because of following StandardError", remove suspected plugins until db/schema.rb becomes correct.

Actions #4

Updated by Daniel Bond almost 13 years ago

Do you have some incompatible plugins installed, by any chance? In my case, stuff_to_do_plugin produces this problem.

You are probably right. I did have the stuff_to_do_plugin installed, and that may well have been the root of the cause.

Actions #5

Updated by Go MAEDA about 9 years ago

  • Status changed from New to Closed

Caused by a plugin, closing this issue.

Actions

Also available in: Atom PDF