Defect #8251

Classic Theme: Missed base line

Added by Anton Lem about 9 years ago. Updated 8 days ago.

Status:ClosedStart date:2011-04-29
Priority:LowDue date:
Assignee:Go MAEDA% Done:

0%

Category:Themes
Target version:4.0.8
Resolution:Fixed Affected version:1.1.2

Description

Tab Control in Classic Theme is looking like this , without bottom base line.
It seems to me, it designed to look like this

tabs1.gif (5.77 KB) Anton Lem, 2011-04-29 08:24

tabs2.gif (5.82 KB) Anton Lem, 2011-04-29 08:24

tabs2-altered.gif (6.82 KB) Mischa The Evil, 2011-04-29 23:00

ScreenShot-2020-06-10-9.02.59.png (64 KB) Mizuki ISHIKAWA, 2020-06-10 02:03

Associated revisions

Revision 19841
Added by Go MAEDA 9 days ago

Classic Theme: Missed base line (#8251).

Patch by Mizuki ISHIKAWA.

Revision 19842
Added by Go MAEDA 8 days ago

Merged r19841 from trunk to 4.1-stable (#8251).

Revision 19843
Added by Go MAEDA 8 days ago

Merged r19841 from trunk to 4.0-stable (#8251).

History

#1 Updated by Mischa The Evil about 9 years ago

I think it was designed rather a bit different, looking like this:

What do you think?

#2 Updated by Anton Lem about 9 years ago

You are absolutely right! I attached my image only for example.

#3 Updated by johann sebatian about 9 years ago

  • Assignee set to johann sebatian

#4 Updated by Mizuki ISHIKAWA 28 days ago

If you delete the line as below, it will look like the screenshot.

diff --git a/public/themes/classic/stylesheets/application.css b/public/themes/classic/stylesheets/application.css
index 523104dcb..5104626b0 100644
--- a/public/themes/classic/stylesheets/application.css
+++ b/public/themes/classic/stylesheets/application.css
@@ -29,7 +29,6 @@ body{ color:#303030; background:#e8eaec; }
 #main a { font-weight: bold; color: #467aa7;}
 #main a:hover { color: #2a5a8a; text-decoration: underline; }
 #content { background: #fff; }
-#content .tabs ul { bottom:-1px; }

 h2, h3, h4, .wiki h1, .wiki h2, .wiki h3 { border-bottom: 0px; color:#606060; font-family: Trebuchet MS,Georgia,"Times New Roman",serif; }
 h2, .wiki h1 { letter-spacing:-1px; }

#5 Updated by Go MAEDA 28 days ago

  • Status changed from New to Confirmed
  • Assignee deleted (johann sebatian)
  • Target version set to Candidate for next major release

#6 Updated by Go MAEDA 26 days ago

  • Target version changed from Candidate for next major release to 4.0.8

LGTM. Setting the target version to 4.0.8.

#7 Updated by Mischa The Evil 26 days ago

Wow, that's a throwback in time...

Go MAEDA wrote:

LGTM.

I agree, but only as long as it does not come with unintended side-effects in other parts of the UI.

#8 Updated by Go MAEDA 25 days ago

Mischa The Evil wrote:

I agree, but only as long as it does not come with unintended side-effects in other parts of the UI.

I have looked tabs in pages generated from the following templates and didn't find problems.

  • app/views/custom_fields/index.html.erb
  • app/views/groups/edit.html.erb
  • app/views/issues/show.html.erb
  • app/views/projects/settings.html.erb
  • app/views/repositories/_changeset.html.erb
  • app/views/settings/edit.html.erb
  • app/views/timelog/_date_range.html.erb
  • app/views/users/edit.html.erb
  • app/views/workflows/edit.html.erb
  • app/views/workflows/permissions.html.erb

#9 Updated by Go MAEDA 9 days ago

  • Status changed from Confirmed to Resolved
  • Assignee set to Go MAEDA
  • Resolution set to Fixed

Committed the patch. Thank you.

#10 Updated by Go MAEDA 8 days ago

  • Status changed from Resolved to Closed

Also available in: Atom PDF