Defect #8596

Make possible to obtain issue_priorities and issue_statuses via RESTful WS

Added by pasquale [:dedalus] almost 8 years ago. Updated over 7 years ago.

Status:ClosedStart date:2011-06-13
Priority:NormalDue date:
Assignee:-% Done:

0%

Category:REST API
Target version:-
Resolution:Duplicate Affected version:

Description

It seems that now is impossible to query RESTful WS to retrieve current used issue_priorities and issue_statuses: should be possibile to make possibile generic a redmine client that can update issues changing priority and status


Related issues

Related to Redmine - Feature #9133: improve error message about missing priority field New 2011-08-26
Related to Redmine - Feature #7180: List of statuses in REST API Closed 2010-12-27
Duplicates Redmine - Feature #7402: REST API - Enumerations New 2011-01-21

History

#1 Updated by Alex Last almost 8 years ago

I need this functionality as well to implement a better data import/export.

#2 Updated by Alex Last over 7 years ago

  • Assignee set to Etienne Massip

One of my users has reported that could not create issues using Redmine Java API:
org.redmine.ta.RedmineException: Priority can't be blank
at org.redmine.ta.RedmineManager.sendRequest(RedmineManager.java:270)
at org.redmine.ta.RedmineManager.createIssue(RedmineManager.java:167)
at org.redmine.ta.Simple.tryCreateIssue(Simple.java:90)
at org.redmine.ta.Simple.main(Simple.java:48)

I was trying to reproduce the problem on several different Redmine installs with Postgresql, MySQL, different Redmine versions, ...

It turned out the user didn't have a "default Issue priority" set in his Redmine administration panel.

A good solution here is for REST API to provide a list of existing priorities with IDs so that remote clients can use them. This is requested in #8596.

A minor easy fix would be to improve the error message: change it from

Priority can't be blank

to

Priority can't be blank. No default priority is set in the Redmine server settings. please use menu "Administration -> Enumerations -> Issue Priorities" to set the default priority.

Users will really appreciate nice error messages!

Etienne, I hope you don't mind if I assign this to you?

#3 Updated by Etienne Massip over 7 years ago

  • Status changed from New to Closed
  • Assignee deleted (Etienne Massip)

Closed as duplicate of #7402.

#4 Updated by Etienne Massip over 7 years ago

  • Resolution set to Duplicate

Also available in: Atom PDF