Project

General

Profile

Actions

Feature #9358

open

Issue attachment permissions

Added by Stanislav German-Evtushenko over 12 years ago. Updated over 7 years ago.

Status:
New
Priority:
Normal
Assignee:
-
Category:
Issues permissions
Target version:
-
Start date:
2011-09-30
Due date:
% Done:

0%

Estimated time:
Resolution:

Description

It would be nice to have an ability to restrict viewing and removing attachments in issues. For example:
- Manager: add & view & remove attachments
- Developer: add & view attachments
- Tester: view attachments


Related issues

Related to Redmine - Feature #21562: Add a permission to prevent user delete issues attachments.New

Actions
Is duplicate of Redmine - Feature #4362: Permissions on attachmentsNew2009-12-08

Actions
Has duplicate Redmine - Patch #24623: Implements CRUD permissions and restrictions to issue attachmentsNew

Actions
Actions #1

Updated by Etienne Massip over 12 years ago

  • Status changed from New to Closed
  • Resolution set to Duplicate

Closed as duplicate of #4362.

Actions #2

Updated by Stanislav German-Evtushenko over 12 years ago

  • Status changed from Closed to Reopened

Etienne, I'm not sure if #4362 is exactly about issues permissions.

Actions #3

Updated by Ron Calibuso over 8 years ago

any update on this?

this would be a great feature to have

Actions #4

Updated by Toshi MARUYAMA over 8 years ago

  • Status changed from Reopened to New
  • Resolution deleted (Duplicate)
Actions #5

Updated by Go MAEDA over 8 years ago

  • Related to Feature #21562: Add a permission to prevent user delete issues attachments. added
Actions #6

Updated by diguang xiao almost 8 years ago

+1

Actions #7

Updated by marcin laskowski over 7 years ago

+1

Actions #8

Updated by Frederico Camara over 7 years ago

Patch for Redmine 3.1, 3.2, 3.3 at #24623

Actions #9

Updated by Mischa The Evil over 7 years ago

  • Has duplicate Patch #24623: Implements CRUD permissions and restrictions to issue attachments added
Actions

Also available in: Atom PDF