Feature #9701

Separate issue author and reporter

Added by Hugues De Keyzer almost 9 years ago. Updated almost 9 years ago.

Status:ClosedStart date:
Priority:NormalDue date:
Assignee:-% Done:

0%

Category:Issues
Target version:-
Resolution:Duplicate

Description

Currently, there is no distinction between the author of an issue and its reporter. For most users, this is probably not a problem, as users enter new issue reports directly into Redmine, so the reporter and the author are actually the same user. However, it is common that clients report issues by email, and these issue reports are entered into Redmine by a developer, for example.

For the latter usage, it would be useful to separate the author and the reporter, while setting the reporter field by default to “<< me >>”. Additionnaly, it would be useful to be able to create new users on the fly at that point, either by searching in the LDAP, or by entering the available information (at least the email address).

Since Redmine 1.2.0, it is of course possible to add a custom field of type User to select a separate reporter, but it has several drawbacks:
  • It is not possible to set it by default to “<< me >>” (the author).
  • The custom field only allows to select users that are a member of the project.
  • The reporter will not receive email notifications about the issue.
  • The issues for which a user is a reporter don’t show up on their page or in their activity feed.

Related issues

Duplicates Redmine - Feature #1739: Add ability to change issue owner New 2008-08-04

History

#1 Updated by Etienne Massip almost 9 years ago

  • Category set to Issues

#2 Updated by Mischa The Evil almost 9 years ago

  • Status changed from New to Closed
  • Resolution set to Duplicate

Closed as a duplicate of #1739 (and its related issues).

FYI: starting from #1739 .note-15 separation between author and reporter is being discussed.

Also available in: Atom PDF