Defect #11888

No e-mail notification for non-members who are watchers

Added by Abdul Halim Mat Ali about 7 years ago. Updated almost 2 years ago.

Status:NewStart date:
Priority:NormalDue date:
Assignee:-% Done:

0%

Category:Email notifications
Target version:-
Resolution: Affected version:

Description

I have to create an issue list here as nobody is answering my query in the forum, the wiki is not clear enough about watchers and I need to know what is happening urgently.

How does the non-member watchers receive the e-mail notification?

This watchers are added by the issue creator and their e-mail notification setting is "issues you're involved in (author or assignee) and about things you watch".


Related issues

Related to Redmine - Feature #8488: Create an 'Involve' mechanism to private issues New
Duplicated by Redmine - Defect #12116: Watchers added as a non-member doesn't receive emails not... Closed

History

#1 Updated by Abdul Halim Mat Ali about 7 years ago

Can somebody point how do I debug this issue?
I am currently looking at the code but have no idea where to start looking at the code that is causing the issue.

#2 Updated by Jean-Philippe Lang about 7 years ago

  • Priority changed from Urgent to Normal

If watchers are not allowed to view the issue (eg. issue from a private project), they won't be notified.

#3 Updated by Abdul Halim Mat Ali about 7 years ago

  • Status changed from New to Resolved

Jean-Philippe, there is a patch at #8488#change-41085 that resolved this.
It also resolved watchers not able to view issues in non-public repository if the visibility type is issue that you are assigned or involved in.
Can this patch be integrated?
I find the patch very useful for my company since we tend to cc issues to management.

#4 Updated by Toshi MARUYAMA about 7 years ago

  • Status changed from Resolved to New

#5 Updated by Tolga Yaman almost 7 years ago

Abdul Halim Mat Ali wrote:

Can this patch be integrated?

+1 to Abdul Halim

#6 Updated by Massimo Rossello over 6 years ago

As far as I understand watchers are not notified of issues in private projects where they are non members because "if they unwatch the issue they loose any contact with the issue, and this may be confusing".

But:
  • this is exactly what happens to users that may only view issues assigned to them, and that are unassigned
  • for my users it is much more confusing to be allowed to add watchers that are not notified, while they think they are!

I also know that watchers are intended just for notifications. But why? Is it meaningful to have notified something that is not visible?

(reasoning over 1.4.7)

Thanks

#7 Updated by Anonymous about 6 years ago

I think that actually this behavior generates confusion.

I have a watcher in an issue in a private project.

Without the patch he doesn't receive any notification about it.
Anyone looking the issue is having a wrong information, thinking he is receiving notifications.

So:

- remove the feature to add non project watchers to an issue
or
- integrate the patch

Thank you.

#8 Updated by Massimo Rossello about 6 years ago

For your information, I have developed a plugin that solves the problem, compatible with Redmine 2.3.2: https://github.com/maxrossello/redmine_extended_watchers

There are two branches:
- in the master branch, watchers are enabled to view the issue (and the project) as long as they are watchers. There is no need to give any role to them into the project. They can interact with the issue in readonly, having just view permissions.
- in the 'with_view_own' branch, a watcher can be added only if he has at least the 'view own or assigned' permission. The issue visibility will be therefore much like that of an assigned user: a) the project is visible anyway, b) the issue is visible just as long as the user is assigned to the issue (in our case as long as he is set as a watcher)

One of the two strategies should be merged into Redmine trunk, I feel. Keeping the standard Redmine behavior was not an option in our company. People were expecting people to be notified while they were not.

#9 Updated by Go MAEDA over 4 years ago

  • Duplicated by Defect #12116: Watchers added as a non-member doesn't receive emails notifications added

#10 Updated by Aníbal Pacheco about 4 years ago

Totally agree with Stefano and Massimo, I've been debugging this issue for days, a watcher should receive notifications, if not, it's not a watcher.

#11 Updated by john aylward over 3 years ago

I just ran into this as well. I may not want a user to watch any ticket in a project. I just want to assign them as a watcher for a single issue and have them receive email notifications. As it is now, this was very confusing and I couldn't figure out what was wrong until I watched my postfix logs and saw redmine was only sending notifications to project members.

#12 Updated by JW Fuchs about 3 years ago

+1

Agreed that non-member watchers in private projects should receive email notifications. Currently there is no effect besides the option causing confusion.

#13 Updated by Heiko Böhme almost 2 years ago

+1

Also available in: Atom PDF