Feature #12579

Ability to assign issues to multiple users

Added by Bishoy Medhat almost 7 years ago. Updated 8 months ago.

Status:NewStart date:
Priority:NormalDue date:
Assignee:-% Done:

0%

Category:Issues
Target version:-
Resolution:

Description

Dear All:

Kindly I need to make "Assignee" Combo box allow "Multi-Selection" because of:

  • Sometimes , Groups don't help me while assigning a specific issue to more than one member.
    This happened in case where the assignees are not gathered in a group. (This happened frequently)
    (Note that: There is an Infinite combination of users!!)
    So , I need the "Assignee" field to be a List Box which allow "Multi-Selection".

Related issues

Duplicated by Redmine - Feature #408: Assign a task to multiple users Closed
Duplicated by Redmine - Feature #15809: issue assign for multiple user Closed
Duplicated by Redmine - Feature #24286: Multiple Asignee ticket Closed

History

#1 Updated by Etienne Massip almost 7 years ago

  • Priority changed from High to Normal

#2 Updated by Jean-Philippe Lang almost 7 years ago

  • Subject changed from Assignee Field to Ability to assign issues to multiple users

#3 Updated by Miodrag Milic almost 7 years ago

Yes, this is troubling because you need to have redmine admin around all the time to make you those groups for entire system in order for you to use them in single project.

There are two solutions to this:
  • Assign field should accept multiple users/groups as suggested
  • Groups should be managable per project (or even per manager or user) and perhaps even savable with adequate rights, similar to the way one can save public queries. I think first solution is far easier, but the second one has potential for aditional future functionalities.

Current solution is not only not practical but it slows down development of the project because aditional person needs to be present for process to continue (redmine admin).

#4 Updated by Daniel Felix almost 7 years ago

We would need this feature as well. This would help us to implement some parallel work.

#5 Updated by # And almost 7 years ago

One more thing - estimated time per user. If 2 or more person works with the same issue (parallel work), it is necessary each person set estimate for his work. So estimated hours per issue need to be a summ.
More complicated, but more powerful.

#6 Updated by Daniel Felix almost 7 years ago

Well I don't think so. Those estimated hours are normally defined by the project manager by some kind of method (for example PERT).
If he defines that this task needs 20 hours, then it's similar if there are two people who work 10 hours or one person who works 20 hours. If they need more, it would be okay. These are just the estimated hours. If they need 30 hours in real, they could add them to the timelog.

Maybe this is just my opinion, but it would make this integration easier. :-)

#7 Updated by Miodrag Milic almost 7 years ago

The estimated hours has nothing to do with this issue.

#8 Updated by Daniel Felix almost 7 years ago

Miodrag Milic wrote:

The estimated hours has nothing to do with this issue.

Well indirectly. Estimated hours are a consequence of a multiuser-ticket. But I agree with you, this could be integrated separately.

#9 Updated by Randy Gobbel over 6 years ago

Ah, I see that this has resurfaced, apparently a duplicate of issue 408, which has been around for quite a while.

As I commented over there, it seems like this could perhaps be some UI sugar over assigning to a group, by creating a hidden group that would actually be dependent on the issue, and would not show up in the regular groups interface. Since some people seem strongly opposed to this whole thing, it could be an optional feature (as assigning to groups already is).

In order to implement this, you would need some sort of flag on groups to designate them with this special status (or have a different type of Group, but that seems heavy-handed). Flagged groups would not show up in the Groups UI. I'm sure there are other wrinkles to this that I haven't thought of, since I'm not very familiar with the code, but at this point I don't see why it wouldn't work.

#10 Updated by Александр Болондзь about 6 years ago

Please, make it on next release, its very easy, just make one more table issues_assignes like groups_users

#11 Updated by Beni Bilme almost 6 years ago

I work in a non profit organization. In the my organization, we have different departments/sections under a director. Directory opens up an issue that will be handled by the organization. An issue usually involves multiple sections/departments. One department always becomes what we call coordinator. Coordinator has the main responsibility about the issue. The others will do their parts but the coordinator will track the issue throuhout whole lifecycle until its completion. Now we are trying to achieve this via one assignee as the coordinator and the watchers as the others or under main issue for the coordinator, we place multiple sub issues for each department/section.
This is cumbersome not directly what we need.
We need multiple assigments, if possible a field to mark who is overall responsible.

#12 Updated by Miodrag Milic almost 6 years ago

This plugin is related: Redshares

#13 Updated by Toshi MARUYAMA almost 6 years ago

  • Related to deleted (Feature #408: Assign a task to multiple users)

#14 Updated by Toshi MARUYAMA almost 6 years ago

  • Duplicated by Feature #408: Assign a task to multiple users added

#15 Updated by Brian Bourke-Martin almost 6 years ago

I manage a small organization of engineers in which tasks are usually delegated to multiple individuals. It is not uncommon for our employee's to miss logging time against a ticket because they are not the assignee, but are on the team. This would assist us in mitigating the error in time reporting due to this.

#16 Updated by Toshi MARUYAMA almost 6 years ago

#17 Updated by Khashchuluun Davaa almost 6 years ago

Hi Toshi MARUYAMA

I didn't see solution. Could you advise step by step?

#18 Updated by Andrey Shpak over 5 years ago

We need this feature too.

#19 Updated by Márcio Lopes over 5 years ago

Hello,

This issue would be very useful.

I think it could be only the possibility to add more than a user in "Assigned to" field.

The time track for the person is registered in the Log time area.

#20 Updated by Jean Risse about 5 years ago

For all the reasons mentioned above: yes it would be great to have this feature implemented. We work in a Scrum environment in which the ability to assign issues to multiple resources would greatly enhance our workflow.

#21 Updated by Garry Paxton almost 5 years ago

Hi,

I am trying to find a simple item of software to manage "Request For Change" approvals. In other words, after a project has been set up and initiated, a change is requested that might impact the budget, timescales, deliverables, etc. If the multiple assignment feature were implemented in Redmine, it would allow me to use Redmine for the purpose of RFC management.... All that is required is a single "issue" which can be assigned to several people, all of whom need to give their "approval" on the change (one might be the Risk Manager, another the Budget Holder, another the Project Sponsor, etc, each with their own responsibilities with regard to the change).

a) Am I pushing my expectations of Redmine into an area that it isn't really designed for, or,
b) is there a Plug-in to manage what I'm hoping to achieve, or
c) would the requested feature permit me to achieve this?

many thanks,
Garry

#22 Updated by Omer Arslan over 4 years ago

Implementing this feature would be very helpful for us too.

#23 Updated by trigal trigal over 4 years ago

+1

#24 Updated by Gabriel Lopes over 4 years ago

There is actually a way of doing this, you can setup some custom fields for those specific areas, lets say you create a tracker called "Change Request", in that tracker you can add the following custom fields:

- Legal Approval (of type boolean)
- Legal Comments (text)
- Revenue Approval (of type boolean)
- Revenue Comments (text)
- etc...

Then you can assign those fields in the workflow by using workflow, that would be better for you use case i believe.

Cheers,

Gabriel

Garry Paxton wrote:

Hi,

I am trying to find a simple item of software to manage "Request For Change" approvals. In other words, after a project has been set up and initiated, a change is requested that might impact the budget, timescales, deliverables, etc. If the multiple assignment feature were implemented in Redmine, it would allow me to use Redmine for the purpose of RFC management.... All that is required is a single "issue" which can be assigned to several people, all of whom need to give their "approval" on the change (one might be the Risk Manager, another the Budget Holder, another the Project Sponsor, etc, each with their own responsibilities with regard to the change).

a) Am I pushing my expectations of Redmine into an area that it isn't really designed for, or,
b) is there a Plug-in to manage what I'm hoping to achieve, or
c) would the requested feature permit me to achieve this?

many thanks,
Garry

#25 Updated by Ling Li over 4 years ago

+1 When we interview candidates, we need a (dynamic) group of people to look at her/his resume, interview, and write feedbacks. Being able to have multiple assignees, OR, having the "Involve" mechanism, would be critical.

#26 Updated by Julius Friedrich about 4 years ago

+1 I don't like losing track of my issues by assigning them to someone else for just a question or something alike. Watcher is not helpful here. Some "Involve"-Mechanism would be nice, just multiple assignees would help alot aswell.

#27 Updated by Dan Muey about 4 years ago

+1 it is invaluable to have various people assigned to various roles, e.g.:

  • Developer: Bob
  • Reviewer: Fred
  • QA: Mary

That way when it is “In progress” everyone knows its in Bob's court. When its in Review Fred should be on it etc

Also very useful for historical info (e.g. How did this bug get past Bob, Fred, and Mary before we noticed it when it made the build fail?).

#28 Updated by Al Pocheche over 3 years ago

+1

#29 Updated by glu tan over 3 years ago

+1 for Dan Muey's comment.

#30 Updated by Inese Ez over 3 years ago

+1 to multipe assignees

#31 Updated by Omer Arslan over 3 years ago

+1 for this functionality. It will really make redmine so powerful. Our company needs this feature very much.

#32 Updated by José Cavalcanti over 3 years ago

+1
I work with Scrum and development-tests cicle, it would be very helpfull if 1 tester and 1 developer could be assigned for some task. In my case if the task becomes Republished, the developer would know (by looking his My Tasks filter). In other hand the tester should know all tasks he must test looking his My Tasks filter.

#33 Updated by Toshi MARUYAMA about 3 years ago

#34 Updated by Freddy L over 2 years ago

+1 to multipe assignees. group too static

#35 Updated by Eugene Belford over 2 years ago

+1
did someone is working on it?

#36 Updated by Ceylan Bozogullarindan about 2 years ago

I am working on it. I have just started to write...

#37 Updated by Susan Kao over 1 year ago

Ceylan Bozogullarindan wrote:

I am working on it. I have just started to write...

+1
If it can have multiple assignees is helpful.
Looking forward to your news~

#38 Updated by Senguttuvan Ganesan over 1 year ago

Even I too agree with this. I had to assign a reading task to multiple people. The task will be considered as done if they are read by all the people. I use other means of tracking to see the task completion by individually assigned users. Currently, using a checkbox list but planned to have some sort of 'Done' capability for each user. In either case, we should have the ability to assign the same task to multiple people. Otherwise, I had to duplicate the task for each user, diluting the visibility of the system.

#39 Updated by precious plum over 1 year ago

I have created a plugin to make user format custom fields have assignee functionality.
the specified user can be notified when issues are modified and reminder mails are sent.
Also, issues can be queried as assignees.

http://www.redmine.org/plugins/custom_users_as_assignees
https://github.com/preciousplum/custom_users_as_assignees

I use this plugin to realize multiple assignees with a user format custom field which has multiple values.

#40 Updated by Mitsuyoshi Kawabata 8 months ago

+1
I often hear this request.

Also available in: Atom PDF