Defect #14658

Wrong activity timezone on user page

Added by Toshi MARUYAMA over 3 years ago. Updated 4 months ago.

Status:ClosedStart date:
Priority:NormalDue date:
Assignee:Jean-Philippe Lang% Done:

0%

Category:Activity view
Target version:3.2.5
Resolution:Fixed Affected version:2.3.2

Description

http://www.redmine.org/users/11192

I use Japanese standard time (+0900) on redmine.org.
#14653#note-3 note-3 should be on 2013-08-10.

user-activity.png (38.3 KB) Toshi MARUYAMA, 2013-08-10 01:46

act.png (76.7 KB) Toshi MARUYAMA, 2014-09-19 05:55

Defect_14658_Patch_Test_resultsScreenShots.zip - Screen Captures of 'Before' and 'After' patch (149 KB) kaz k, 2017-01-05 05:08


Related issues

Related to Redmine - Defect #1048: Day grouping on Activity view ignores user's time zone Closed 2008-04-12
Related to Redmine - Defect #10996: Time zones lost when upgrading from Redmine 1.4 to 2.0 Closed
Duplicated by Redmine - Defect #24707: Activity in User Profile shows incorrect date/time, depen... Closed

Associated revisions

Revision 16138
Added by Jean-Philippe Lang 4 months ago

Wrong activity timezone on user page (#14658).

Patch by Go MAEDA.

History

#1 Updated by Toshi MARUYAMA over 3 years ago

CI server time is a head of 2 hours.
Now, It is 2013-08-09 23:50 UTC.
But CI server time is Sat Aug 10 03:50:03 +0200 2013.
http://www.redmine.org/builds/index.html

#2 Updated by Etienne Massip over 3 years ago

  • Category set to Website (redmine.org)

#3 Updated by Matthew Peterson over 2 years ago

I'm fairly sure this is a duplicate of #1048

#4 Updated by Toshi MARUYAMA over 2 years ago

  • Category deleted (Website (redmine.org))

#5 Updated by Toshi MARUYAMA over 2 years ago

  • Related to Defect #1048: Day grouping on Activity view ignores user's time zone added

#6 Updated by Toshi MARUYAMA over 2 years ago

Matthew Peterson wrote:

I'm fairly sure this is a duplicate of #1048

No.
I mean this issue is on user page.
http://www.redmine.org/users/11192

#8 Updated by Kit Grose about 1 year ago

This issue is affecting our installation too. Interestingly, it seems to only affect one of our users (not all). That user has the same timezone set in their preferences as everyone else.

When other users visit that user's page it shows up incorrectly, and when that user visits any other user's page, the times are shown correctly.

We have v2.3.0.stable installed, though.

#9 Updated by Ewan Makepeace 5 months ago

+1

#10 Updated by Go MAEDA 4 months ago

  • Category set to Activity view
  • Target version set to 3.2.5

This issue can be fixed by the following patch.
ActivitiesController#show have been fixed in r9726 (diff) in order to handle time zones properly. This patch applies the same fix to UsersController#show.

Index: app/controllers/users_controller.rb
===================================================================
--- app/controllers/users_controller.rb    (revision 16111)
+++ app/controllers/users_controller.rb    (working copy)
@@ -74,7 +74,7 @@
     respond_to do |format|
       format.html {
         events = Redmine::Activity::Fetcher.new(User.current, :author => @user).events(nil, nil, :limit => 10)
-        @events_by_day = events.group_by(&:event_date)
+        @events_by_day = events.group_by {|event| User.current.time_to_date(event.event_datetime)}
         render :layout => 'base'
       }
       format.api

#11 Updated by Go MAEDA 4 months ago

  • Related to Defect #10996: Time zones lost when upgrading from Redmine 1.4 to 2.0 added

#12 Updated by Go MAEDA 4 months ago

  • Duplicated by Defect #24707: Activity in User Profile shows incorrect date/time, dependent to Time zone added

#13 Updated by Jean-Philippe Lang 4 months ago

  • Status changed from New to Resolved
  • Assignee set to Jean-Philippe Lang
  • Resolution set to Fixed

Fix committed, thanks.

#14 Updated by kaz k 4 months ago

Hi, I came here from #24707.
I tested the patch in note 10 (#14658#note-10).
Environment
  • Redmine 3.1.1 (Windows) (not the target version :-) )
  • Time Zone of the viewer: GMT+09:00(Tokyo).

Result
The patch worked well. Attached is the screen captures of 'Before' and 'After' patch with comments (Zipped).

Thank you.

#15 Updated by Go MAEDA 4 months ago

kaz k, thanks for the screenshots.
This problem will be fixed in upcoming 3.2.5 / 3.3.2 / 3.4.0.

Your #24707 triggered me to investigate this issue. Thank you again.

#16 Updated by Jean-Philippe Lang 4 months ago

  • Status changed from Resolved to Closed

Also available in: Atom PDF