Patch #21159

Hide empty <ul> on project overview

Added by Felix Gliesche almost 3 years ago. Updated almost 3 years ago.

Status:ClosedStart date:
Priority:NormalDue date:
Assignee:Felix Gliesche% Done:

0%

Category:UI
Target version:3.2.0

Description

When there is either no homepage, no subprojects or no visible custom fields for a project present, an empty <ul> is being rendered on a projects overview. Due to browser presets, this <ul> can cause a space which resolves in an incorrect alignment of the default boxes (issue tracking, members). See the screenshot before_patch.png for this behaviour.

This patch prevents the empty <ul> from being rendered when none of the above conditions are met. The attached screenshot after_patch.png shows how it looks when the patch is being applied.

after_patch.png (56.6 KB) Felix Gliesche, 2015-11-05 14:37

before_patch.png (44.4 KB) Felix Gliesche, 2015-11-05 14:37

0001-Hide-empty-ul-on-project-overview.patch Magnifier (1.08 KB) Felix Gliesche, 2015-11-05 17:57


Related issues

Duplicated by Redmine - Patch #6102: Project page: issues and members box are not lined up Closed 2010-08-11

Associated revisions

Revision 14797
Added by Jean-Philippe Lang almost 3 years ago

Hide empty ul on project overview (#21159).

Patch by Felix Gliesche.

History

#1 Updated by Felix Gliesche almost 3 years ago

  • File 0001-Hide-empty-ul-on-project-overview.patch added

Housekeeping: The first patch was missing correct indentation.

#2 Updated by Jan from Planio www.plan.io almost 3 years ago

  • File deleted (0001-Hide-empty-ul-on-project-overview.patch)

#3 Updated by Jan from Planio www.plan.io almost 3 years ago

  • File deleted (0001-Hide-empty-ul-on-project-overview.patch)

#4 Updated by Jan from Planio www.plan.io almost 3 years ago

  • Assignee set to Felix Gliesche

This is not working yet as intended. We're uploading a new patch as soon as we have one...

#5 Updated by Felix Gliesche almost 3 years ago

Here it is, sorry for the confusion.

#6 Updated by Jean-Philippe Lang almost 3 years ago

  • Status changed from New to Closed
  • Target version set to 3.2.0

Thanks.

#7 Updated by Go MAEDA almost 3 years ago

  • Duplicated by Patch #6102: Project page: issues and members box are not lined up added

Also available in: Atom PDF