Defect #24271

htmlentities warning

Added by James H 10 months ago. Updated 5 months ago.

Status:ClosedStart date:
Priority:LowDue date:
Assignee:-% Done:

0%

Category:Gems support
Target version:3.2.6
Resolution:Fixed Affected version:3.3.1

Description

During my migration to 3.3.1, I got this warning:

.../ruby/gems/2.3.0/gems/htmlentities-4.3.1/lib/htmlentities/mappings/expanded.rb:465: warning: key "inodot" is duplicated and overwritten on line 466

Installing htmlentities 4.3.4 seems to resolve this message. Have not had any issues with htmlentities yet.


Related issues

Duplicated by Redmine - Defect #24917: duplicated key upgrading from 3.3.1 to 3.3.2 version Closed

Associated revisions

Revision 16485
Added by Toshi MARUYAMA 5 months ago

Gemfile: explicitly use rbpdf 1.19.1 (#22335, #24271)

Revision 16486
Added by Toshi MARUYAMA 5 months ago

Merged r16485 from trunk to 3.3-stable (#22335, #24271)

Gemfile: explicitly use rbpdf 1.19.1.

Revision 16487
Added by Toshi MARUYAMA 5 months ago

Merged r16485 from trunk to 3.2-stable (#22335, #24271)

Gemfile: explicitly use rbpdf 1.19.1.

Revision 16507
Added by Jean-Philippe Lang 5 months ago

Reverts to rbpdf 1.19.0 for now.

Using rbpdf-font 1.19.1

Encoding::UndefinedConversionError: "\x81" to UTF-8 in conversion from Windows-1
252 to UTF-8
An error occurred while installing rbpdf (1.19.1), and Bundler cannot continue.
Make sure that `gem install rbpdf -v '1.19.1'` succeeds before bundling.

Revision 16512
Added by Toshi MARUYAMA 5 months ago

Merged r16507 from trunk to 3.3-stable (#22335, #24271)

Gemfile: use rbpdf 1.19.0.

Revision 16513
Added by Toshi MARUYAMA 5 months ago

Merged r16507 from trunk to 3.2-stable (#22335, #24271)

Gemfile: use rbpdf 1.19.0.

Revision 16520
Added by Jean-Philippe Lang 5 months ago

Use rbpdf 1.19.2 (#22335, #24271).

History

#2 Updated by Go MAEDA 7 months ago

  • Duplicated by Defect #24917: duplicated key upgrading from 3.3.1 to 3.3.2 version added

#3 Updated by Jun NAITOH 5 months ago

This problem fixed by rbpdf 1.19.1.
please bundle update.

#4 Updated by Go MAEDA 5 months ago

  • Status changed from New to Closed
  • Resolution set to Fixed

Jun NAITOH wrote:

This problem fixed by rbpdf 1.19.1.
please bundle update.

I confirmed that this issue can be fixed by executing bundle update.
Naitoh-san, thank you for maintaining rbpdf.

#5 Updated by Toshi MARUYAMA 5 months ago

  • Target version set to 3.2.6

#6 Updated by Jean-Philippe Lang 5 months ago

  • Status changed from Closed to Reopened

An error occurs when running bundle update with rbpdf 1.19.1 under windows:

Using rbpdf-font 1.19.1

Encoding::UndefinedConversionError: "\x81" to UTF-8 in conversion from Windows-1
252 to UTF-8
An error occurred while installing rbpdf (1.19.1), and Bundler cannot continue.
Make sure that `gem install rbpdf -v '1.19.1'` succeeds before bundling.

#7 Updated by Jean-Philippe Lang 5 months ago

3.2.6 release is planned for this week-end, I'll have to revert to previous rbpdf version unless a fixed version of rbpdf is released. Thanks.

#8 Updated by Toshi MARUYAMA 5 months ago

What Ruby version do you use?
I cannot reproduce on ruby 2.2.6p396 (2016-11-15 revision 56800) [i386-mingw32] in Japanese Windows 10.

#9 Updated by Toshi MARUYAMA 5 months ago

  • Status changed from Reopened to New
  • Target version changed from 3.2.6 to 3.4.0

I can confirm rbpdf 1.19.1 cannot be installed on Ruby 1.9.3 and 2.0 on Windows.
I think there is no benefit to continue support Ruby 1.9.3 and 2.0.
So I create #25538.

#10 Updated by Toshi MARUYAMA 5 months ago

  • Blocked by Feature #25538: Drop support for Ruby 2.2.1 and ealier, 2.2.2+ is now required added

#11 Updated by Toshi MARUYAMA 5 months ago

  • Resolution deleted (Fixed)

#12 Updated by Go MAEDA 5 months ago

  • Target version changed from 3.4.0 to 3.2.6

Toshi's test shows that the problem reported by Jean-Phillipe (#24271#note-6) occurs only with older versions of Ruby.

I think that it would be better to pin rbpdf version for Ruby <=2.0 only. Many Redmine user in Japan are annoyed with the defect #22335 due to rbpdf 1.19.0.

Index: Gemfile
===================================================================
--- Gemfile    (revision 16517)
+++ Gemfile    (working copy)
@@ -24,7 +24,7 @@

 # Windows does not include zoneinfo files, so bundle the tzinfo-data gem
 gem 'tzinfo-data', platforms: [:mingw, :x64_mingw, :mswin]
-gem "rbpdf", "1.19.0" 
+gem "rbpdf", (RUBY_VERSION >= "2.1" ? "~> 1.19.1" : "1.19.0")

 # Optional gem for LDAP authentication
 group :ldap do

#13 Updated by Toshi MARUYAMA 5 months ago

  • Target version changed from 3.2.6 to 3.4.0

I want to prevent old Ruby user will say "ChangeLog says htmlentities warning fixed, but my Redmine still warn on my Redmine why?".

#14 Updated by Jun NAITOH 5 months ago

Jean-Philippe Lang wrote:

An error occurs when running bundle update with rbpdf 1.19.1 under windows:

Sorry, I will fix today, this problem.

3.2.6 release is planned for this week-end, I'll have to revert to previous rbpdf version unless a fixed version of rbpdf is released. Thanks.

Please wait.

#15 Updated by Go MAEDA 5 months ago

Toshi MARUYAMA wrote:

I want to prevent old Ruby user will say "ChangeLog says htmlentities warning fixed, but my Redmine still warn on my Redmine why?".

How about updating Gemfile as I wrote in #24271#note-12 without closing this issue (without listing this issue in CHANGELOG)? We can list this issue after dropping support for older versions of Ruby. I think that it is beneficial for users to deliver deliver fixes as soon as possible.

As Holger Just wrote in #25538#note-7, I think dropping Ruby 2.0 support right now is somewhat problematic.

#16 Updated by Jun NAITOH 5 months ago

Jun NAITOH wrote:

Jean-Philippe Lang wrote:

An error occurs when running bundle update with rbpdf 1.19.1 under windows:

Sorry, I will fix today, this problem.

3.2.6 release is planned for this week-end, I'll have to revert to previous rbpdf version unless a fixed version of rbpdf is released. Thanks.

Please wait.

This problem fixed by rbpdf 1.19.2.
please bundle update.

#17 Updated by Jean-Philippe Lang 5 months ago

  • Status changed from New to Resolved
  • Target version changed from 3.4.0 to 3.2.6
  • Resolution set to Fixed

Jun NAITOH wrote:

This problem fixed by rbpdf 1.19.2.
please bundle update.

Great! Thank you for fixing this.

#18 Updated by Toshi MARUYAMA 5 months ago

  • Blocked by deleted (Feature #25538: Drop support for Ruby 2.2.1 and ealier, 2.2.2+ is now required)

#19 Updated by Jean-Philippe Lang 5 months ago

  • Status changed from Resolved to Closed

Also available in: Atom PDF