Defect #25064

Issue description edit link corrupted in low resolution

Added by Vasili Korol 7 months ago. Updated 4 months ago.

Status:ClosedStart date:
Priority:NormalDue date:
Assignee:Jean-Philippe Lang% Done:

0%

Category:UI - Responsive
Target version:3.3.4
Resolution:Fixed Affected version:3.2.4

Description

When editing an issue in a low resolution (width < 900px), the "Edit" link loses it's icon and is truncated to "dit" (see image)

Environment:
  Redmine version                3.2.4.stable
  Ruby version                   2.0.0-p384 (2014-01-12) [x86_64-linux-gnu]
  Rails version                  4.2.7.1
  Environment                    production
  Database adapter               Mysql2
SCM:
  Subversion                     1.8.8
  Git                            1.9.1
  Filesystem                     
Redmine plugins:
  advanced_roadmap_v2            2.4.2

redmine-error.jpg (146 KB) Vasili Korol, 2017-02-14 10:18

0001-Fix-unintended-word-wrap-for-edit-link.patch Magnifier (753 Bytes) Felix Gliesche, 2017-05-30 10:55

Associated revisions

Revision 16627
Added by Jean-Philippe Lang 4 months ago

Fix edit description link in low resolution (#25064).

Patch by Felix Gliesche.

History

#1 Updated by Go MAEDA 7 months ago

  • Category set to UI - Responsive

I confirmed the problem with Chrome 56.0.2924.87 (Mac).
No problem with Firefox or Safari.

#2 Updated by Vasili Korol 7 months ago

Indeed. I only see this in Chrome (56.0.2924.87), but not in Firefox (51.0.1). Both in Linux.
Safari 10 does not show the issue either (in iOS)

#3 Updated by Mischa The Evil 7 months ago

  • Status changed from New to Confirmed

Go MAEDA wrote:

I confirmed the problem with Chrome 56.0.2924.87 (Mac).
No problem with Firefox or Safari.

Vasili Korol wrote:

Indeed. I only see this in Chrome (56.0.2924.87), but not in Firefox (51.0.1). Both in Linux.
Safari 10 does not show the issue either (in iOS)

Based on these comments this issue is confirmed, setting status as such.

#4 Updated by Felix Gliesche 4 months ago

The problem is the attribute:

word-wrap: break-word;

of the .box that wraps this form. This leads to a line break for the specified element.

I am attaching a patch that resets the word-wrap for this element for the mobile resolution.

#5 Updated by Vasili Korol 4 months ago

Applying the styles from the patch above fixes the problem in Redmine 3.2.4 in Chrome 58.0.3029.110.

#6 Updated by Go MAEDA 4 months ago

  • Target version set to 3.3.4

Thank you for posting the patch. The problem was fixed.

Setting target version to 3.3.4 (merging the patch to 3.2-stable branch requires manual merge).

#7 Updated by Jean-Philippe Lang 4 months ago

  • Subject changed from Corrupt layout on the issue editing page in low resolution to Issue description edit link corrupted in low resolution
  • Status changed from Confirmed to Resolved
  • Assignee set to Jean-Philippe Lang
  • Resolution set to Fixed

Patch committed, thanks.

#8 Updated by Sharique Sarwar 4 months ago

  • File GROUP FORMATION.docx added

#9 Updated by Go MAEDA 4 months ago

  • File deleted (GROUP FORMATION.docx)

#10 Updated by Jean-Philippe Lang 4 months ago

  • Status changed from Resolved to Closed

Also available in: Atom PDF