Defect #25137

Assigning a parent in issue properties does not work (Error "Parent task is invalid") although the Parent exists

Added by Astrid Krafczyk-Kralitschka 8 months ago. Updated 7 months ago.

Status:ClosedStart date:
Priority:NormalDue date:
Assignee:-% Done:

0%

Category:Issues
Target version:-
Resolution:Duplicate Affected version:3.1.3

Description

Affected Version is 3.1.6stable 15842 (version is not in the drop-down..)

The parent issue definitely exists. Another issue is assigned as subtask but the other subtask has been added via the parent (create subtaks)

The second Issue has been created as the normal issue. After saving I wanted to add parent issue via the properties...and that failed (see attached screenshot)

parent_error.png (44.4 KB) Astrid Krafczyk-Kralitschka, 2017-02-21 10:36


Related issues

Duplicates Redmine - Defect #13654: Can't set parent issue when issue relations among child i... Closed

History

#1 Updated by Marius BALTEANU 8 months ago

You should update you Redmine instance to 3.3.* because in version 3.3.0 there were multiple issues fixed related to issue relations (#17580, #8628, #13654).

#2 Updated by Astrid Krafczyk-Kralitschka 8 months ago

Marius BALTEANU wrote:

You should update you Redmine instance to 3.3.* because in version 3.3.0 there were multiple issues fixed related to issue relations (#17580, #8628, #13654).

Hi,

thx a lot. Gonna tell our administrator. 3.3.0 is a stable version?

#3 Updated by Marius BALTEANU 8 months ago

Redmine 3.3.2 is the latest stable version. You can check by yourself in the News section or in the Changelog page from wiki.

#4 Updated by Mischa The Evil 8 months ago

  • Status changed from New to Needs feedback

#5 Updated by Go MAEDA 8 months ago

  • Duplicates Defect #13654: Can't set parent issue when issue relations among child issues are present added

#6 Updated by Go MAEDA 8 months ago

  • Status changed from Needs feedback to Closed
  • Resolution set to Duplicate

As Marius BALTEANU wrote, I think this issue is a duplicate of #13654. It was fixed in Redmine 3.3.0. Please reopen this issue if the problem persists after updating to Redmine 3.3.x.

In Redmine <= 3.2.x, you cannot set parent task if some of related issues has same parent task.

#7 Updated by Astrid Krafczyk-Kralitschka 7 months ago

OK. Thx. Will wait if our admin will do the update.

Also available in: Atom PDF