Feature #3169

Multiple repositories for projects

Added by Arkady Marchenko over 5 years ago. Updated almost 3 years ago.

Status:ClosedStart date:2009-04-14
Priority:NormalDue date:
Assignee:-% Done:

0%

Category:SCM
Target version:-
Resolution:Duplicate

Description

May be this be interesting not only me - i think subject can be useful in some cases


Related issues

Related to Patch #9359: invert project <-> repository relationship New 2011-09-30
Duplicates Feature #779: Multiple SCM per project Closed 2008-03-04

History

#1 Updated by David Holm over 5 years ago

I would like to second this feature request. At work we have three repositories for one of our projects. One contains our platform independent software platform and the two others contain toolchains and platform specific code for the hardware platforms that we support.
Most bugs are related to our own software but some are fixed in one of the toolchain repositories and it would be nice if they could all reference the same master project.

#2 Updated by Thomas M about 5 years ago

I'm also looking for this feature.

In my case projects are using several folders of the same repository (a subset of all the folders available).

#3 Updated by Babar O'Cap about 5 years ago

I've a workaround :
First of all, create a new project ProjectB, who will be a sub-project of ProjectA
and in Modules panel only enable repository, if you just want an other repository of course ;)
Finally download and apply my last patch of Issue #3346

Now, when you are in ProjectA, you can link to your second repository with this wiki syntax : r:ProjectB:r1 or commit:ProjectB:a85130f

#4 Updated by Adam Piotr ┼╗ochowski about 5 years ago

I think your patch answers previously asked for feature:
#3216 - ability to link commit/revision across projects through wiki

On a related note, there was some work done on nicer handling of a project with multiple repositories (with patches):
#3087 - Commit on one project can reference issue from another, related, project.
#3376 - Commit properly linking across projects (when issue is moved, or through #3087)

Basically, make parent project with issues. Make children projects with repositories (without issues). Now your parent project will feed children commits and close your issues.

Kind regards

Adam ┼╗ochowski

#5 Updated by Marc Mengel about 5 years ago

I would vote for this, too. Especially for Git repositories -- since you can only checkout whole repositories, more smaller repositories makes sense. I think this sub-project model makes good sense, too.

#6 Updated by William Baum about 5 years ago

The patch in #3346 sounds very interesting, as the ability to do cross project repository source links is something I'm very interested in.

However, the main thrust of this request is the ability to associate revisions from multiple repositories, which I now have working well.

The patch in #3087 allows linking repositories and parent project repositories, and I've now updated that issue with a slight change that allows revisions in any tracked repository to be associated with issues in any project, which for most practical purposes allows unlimited repositories per project.

--Bill

#7 Updated by CS Wong almost 5 years ago

I'd vote for this too. Creating multiple sub-projects if we have multiple repos is quite a hassle. I wanted to move our support issue tracker over to redmine but we have about 12 repos and creating 12 sub-projects in order to allow us to see the changesets associated to issues is really troublesome.

#8 Updated by Christian Ceelen almost 5 years ago

I would vote for this feature too. Given for instance a software containing many small components each with it's own repository and distribution mechanism. Then a single project that would require a series of small modifications of a subset of these components does not need to open a new sub project for every component. Especially if several different repository types have to be mixed within one project.

#9 Updated by Kai Krakow almost 5 years ago

Marc Mengel wrote:

Especially for Git repositories -- since you can only checkout whole repositories, more smaller repositories makes sense. I think this sub-project model makes good sense, too.

In the special case of a distributed vcs like Git et al this is obviously useful to track multiple developers forks which are to be merged back into a main project.

I also want to add that it is currently not possible to relocate a repository url (eg if it changed the hoster). Of course one should keep in mind that there may be references to commits in the issues and comments (eg "Code Review" plugin makes heavy use of that) and these links need to be rewriten which may be impossible if you not only move to another host but also move to another vcs. This is where having multiple repositories per project comes in handy. One should be able to define some sort of translation mapping from old commit ids to new ones and optionally freezing the old repository url so it can no longer receive new commit links.

#10 Updated by Robert Maron almost 4 years ago

I would definitely vote 'yes' for this feature.
We create subprojects to cover multiple repositories, but this is not the right way to do things ;)

#11 Updated by Tatyana Matveyeva almost 4 years ago

Since we have several repositories for single project, I would vote for this feature too.

#12 Updated by kid smart over 3 years ago

vote yes for this feature

#13 Updated by Dave Abrahams over 3 years ago

+1

#14 Updated by Emerson J. Morgado Brito over 3 years ago

I vote yes for this feature too, we have several repositories for a project.

#15 Updated by John Pataki over 3 years ago

+1

#16 Updated by Joshua Rieken over 3 years ago

+1

#17 Updated by Andy Bolstridge over 3 years ago

Issue 779 is a duplicate of this one and has more activity, perhaps its worth closing this and directing all comments to that issue instead.

#18 Updated by Toshi MARUYAMA over 3 years ago

  • Category changed from Projects to SCM

#20 Updated by Louis Simons over 3 years ago

+1, would be nice to have seperate repos for hardware and software aspects of a project

#21 Updated by Patrick Cummins over 3 years ago

+1

#22 Updated by Pavel Pivovarov over 3 years ago

+1

#23 Updated by Don Doffe about 3 years ago

+1

#24 Updated by Charles Sporkman almost 3 years ago

+1

#25 Updated by Terence Mill almost 3 years ago

We would use this feature to have on repsoitory for source code (developer team)and one one for documentation (analysts team), where the the last one will accessivle via webdav from windows explorer (http://www.redmine.org/projects/redmine/wiki/PluginWebDav).

The read/write rights per repository should be setable per role.
+1

#26 Updated by Andy Bolstridge almost 3 years ago

I disagree that repo permissions should be part of redmine - they are something that should be set in SVN itself. Redmine just provides the links to the repo.

Still, it's another example why there should be multiple repositories per project.

I implemented the patch, it works for the general case, but it does not work with many plugins that expect a single repo. So I think this really needs to be added to the main codebase.

Also, can we close this bug and add everything to bug #779 which is the original report for multip repos per project.

#27 Updated by Jean-Philippe Lang almost 3 years ago

  • Status changed from New to Closed
  • Resolution set to Duplicate

Dup of #779.

Also available in: Atom PDF