Feature #3976

Hide custom fields from certain roles

Added by Nils Kluge about 8 years ago. Updated over 4 years ago.

Status:ClosedStart date:2009-10-06
Priority:NormalDue date:
Assignee:-% Done:

0%

Category:Issues
Target version:-
Resolution:Duplicate

Description

It would be a great feature to show/hide custom fields in a project depending on the user's role.

We have some cutomers looking into our projects using the role customer and adding issues (defects / features).

Today we added a custom field that marks an issue as maintenance issue.
But this flag indicates an internal state and should not be seen by the customer.

It would be great to configure the roles that can see a custom field in the project's configuration.


Related issues

Related to Redmine - Feature #3088: Estimated hours field able to hide role based New 2009-04-01
Related to Redmine - Feature #7955: Display issue field depending on role New 2011-03-22
Duplicates Redmine - Feature #5037: Role-based issue custom field visibility Closed 2010-03-10

History

#1 Updated by Marcel Hochuli almost 7 years ago

I would double this feature! Are there plans when this feature will be implemented?

#2 Updated by pasquale [:dedalus] over 6 years ago

+1

#3 Updated by Stefan Langenmaier over 6 years ago

I have written a plugin for this purpose.

Check it out: https://github.com/stefan-langenmaier/redmine_permits

#4 Updated by James Silver over 4 years ago

Definitely need this functionality! We've been trying to figure out a way of adding an additional 'Tags' field allowing us to privately categorize tickets away from the eyes of the client.

We have found a workaround which sort-of works for our use case for the moment (if anyone else needs this):

1. Add #hashtags to your issue in private comments (private comments were added to Redmine in #1554)
2. Use the issue search page to search for these hashtags (only those who are allowed to view private comments will get the search results).

This is obviously a very limited and hacky workaround and is no substitute for proper support for permissions on custom fields, but it may help someone else!

#5 Updated by Wim DePreter over 4 years ago

duplicate of #5037 ?

#6 Updated by Toshi MARUYAMA over 4 years ago

  • Status changed from New to Needs feedback

#7 Updated by Toshi MARUYAMA over 4 years ago

  • Related to Feature #5037: Role-based issue custom field visibility added

#8 Updated by Nils Kluge over 4 years ago

Seems to be closed by #5037

#9 Updated by Toshi MARUYAMA over 4 years ago

  • Status changed from Needs feedback to Closed
  • Resolution set to Duplicate

Thank you for your feedback.

#10 Updated by Toshi MARUYAMA over 4 years ago

  • Related to deleted (Feature #5037: Role-based issue custom field visibility)

#11 Updated by Toshi MARUYAMA over 4 years ago

  • Duplicates Feature #5037: Role-based issue custom field visibility added

Also available in: Atom PDF