Feature #7239

Allow some users to add / edit time entries on behalf of other users

Added by Arnaud Lesauvage over 7 years ago. Updated 3 months ago.

Status:ClosedStart date:2011-01-06
Priority:NormalDue date:
Assignee:-% Done:

0%

Category:Time tracking
Target version:-
Resolution:Duplicate

Description

In our company, some users are not responsible for entering there spent time entries. The project manager does it for them.

There does not seem to be a way now in redmine to add/edit time entries on behalf of other users, but I think this would be a nice feature.

This has also been requested in the following topics :
http://www.redmine.org/boards/2/topics/14973
http://www.redmine.org/boards/1/topics/12158
http://www.redmine.org/boards/1/topics/9885

There is a patch that was once submitted to make this possible, but I believe that it does not work anymore :
#3848

This issue was also reported on the redmine backlog plugin, but I believe it should have been reported here instead :
http://dev.redminebacklogs.net/issues/231

I don't know if this would require much work (sorry, I am not familiar with Ruby at all), but would really like to see this in a future release !


Related issues

Related to Redmine - Feature #9276: Log Time on an issue assigned to other Closed 2011-09-19
Duplicated by Redmine - Feature #6486: Log time for other users Closed 2010-09-25
Duplicates Redmine - Feature #3848: Allow the current user to record the time spent by anothe... New 2009-09-11

History

#1 Updated by Lars Dornheim almost 7 years ago

+1

We also need this functionality for some roles. When project members are ill or on holidays and forgot to log their spent times, then we can not set it in the system. But we can change their existing time log entries. Why we should not be able to create new ones on their behalf? We really need this functionality.

#2 Updated by Jérôme BATAILLE almost 7 years ago

We also need this feature, we will include it in a larger enhancement

#3 Updated by Alexey Abraham almost 7 years ago

+1
I desperately need such a functionality too.

#4 Updated by Brian Kjelin Olsen over 6 years ago

+1
That's the function we are missing.
We are wasting so much time trying to pull colleagues and follow up time records.
It is also cumbersome to five people each will record time for a meeting if one can do it for them all five at once.

#5 Updated by Brian Kjelin Olsen over 6 years ago

Also see feature #8505

#6 Updated by Filou Centrinov over 5 years ago

In our company, some users are not responsible for entering there spent time entries. The project manager does it for them.

Just create a new role for the project manager. You can configure rights of adding/viewing/editing in "roles and permissions".
Duplicates: #6486, #9276

#7 Updated by Brian Kjelin Olsen over 5 years ago

Filou Centrinov wrote:

In our company, some users are not responsible for entering there spent time entries. The project manager does it for them.

Just create a new role for the project manager. You can configure rights of adding/viewing/editing in "roles and permissions".
Duplicates: #6486, #9276

The problem is that it isn't possible to get permissions to add time entries for others, you can only edit.

#8 Updated by Toshi MARUYAMA over 5 years ago

  • Description updated (diff)

#9 Updated by Marco Descher 11 months ago

+1 for this request

#10 Updated by Marius BALTEANU 3 months ago

  • Status changed from New to Closed
  • Resolution set to Duplicate

I've added a new patch which adds this feature to #3848. I'm closing this ticket as duplicate because I don't find any different request here.

#11 Updated by Marius BALTEANU 3 months ago

  • Related to deleted (Feature #3848: Allow the current user to record the time spent by another one.)

#12 Updated by Marius BALTEANU 3 months ago

  • Duplicates Feature #3848: Allow the current user to record the time spent by another one. added

Also available in: Atom PDF