How may i use redmine on my Xampp server?

Added by Prince Shahnawaz almost 13 years ago

Hello Everybody,

I have found that Redmine project might be useful for our needs. Therefore,I have been trying to setup Redmine on my LocalHost(Xampp based). But I really couldn't find any way to setup on my Xampp as like other PHP based project are running.

I also made some little changes on my httpd.conf file as fellows ---
AddHandler cgi-script .cgi .pl .asp .rb

Please help me out.. :(

Replies (11)

RE: How may i use redmine on my Xampp server? - Added by Felix Schäfer almost 13 years ago

RedmineInstall or HowTo_configure_Apache_to_run_Redmine, though on apache I'd advise using passenger (last paragraph in the second link, lots of google hits).

RE: How may i use redmine on my Xampp server? - Added by Prince Shahnawaz almost 13 years ago

I followed through your suggested link. But at finally,I am having following error :

Application error

Rails application failed to start properly

And Inside the Apache Error Log report says ...

[Wed Feb 24 10:47:40 2010] [error] [client 127.0.0.1] (OS 3)The system can not find the path specified. : couldn't create child process: 720003: dispatch.cgi
[Wed Feb 24 10:47:40 2010] [error] [client 127.0.0.1] (OS 3)The system can not find the path specified. : couldn't spawn child process: C:/xampp/htdocs/redmine/public/dispatch.cgi

Please Help me out :(

RE: How may i use redmine on my Xampp server? - Added by Jeffrey Jones almost 13 years ago

If you are running on windows your best bet is to use mongrel as the redmine application server and reverse proxy via xampp.

My own personal opinion is that using mod_cgi or mod_fcgi is asking for trouble

RE: How may i use redmine on my Xampp server? - Added by Prince Shahnawaz almost 13 years ago

I am still having same error message, I dont know where is the problem. I have been trying to fix it up but couldnt able to fix it up. please help me. :(

RE: How may i use redmine on my Xampp server? - Added by Prince Shahnawaz almost 13 years ago

Hello Jeffrey,

I really dont know if i could able to use Redmine without using mod_cgi or mod_fcgi.

Because, I become totally confused now, And seems no way to run Redmine on the Xampp.

If you really want to help me one more time, then i would be so glad so please let me know how could i run Redmine on the xampp ?

thanks Jeffrey

RE: How may i use redmine on my Xampp server? - Added by Jeffrey Jones almost 13 years ago

A detailed guide on getting rails applications working on windows can be found here:

http://www.napcsweb.com/howto/rails/deployment/RailsWithApacheAndMongrel.pdf

Make sure you remove all your cgi/fcgi configuration stuff before trying the above.

RE: How may i use redmine on my Xampp server? - Added by Prince Shahnawaz almost 13 years ago

Now, I have having error message as fellows ...

Application error

Rails application failed to start properly

RE: How may i use redmine on my Xampp server? - Added by Jeffrey Jones almost 13 years ago

If you want us to help you you need to help us. "Rails application failed to start properly" tells us nothing useful.

Look at the log file and see what the last error is then paste that in here.

There are loads of "How to ask for help on the internet" posts. Have a look at them so that you know what we need to help.

RE: How may i use redmine on my Xampp server? - Added by Prince Shahnawaz almost 13 years ago

[Tue Mar 02 18:21:32 2010] [warn] module cgi_module is already loaded, skipping
[Tue Mar 02 18:21:32 2010] [warn] NameVirtualHost *:80 has no VirtualHosts
[Tue Mar 02 18:21:33 2010] [warn] module cgi_module is already loaded, skipping
[Tue Mar 02 18:21:33 2010] [warn] NameVirtualHost *:80 has no VirtualHosts
PHP Warning: Directive 'magic_quotes_gpc' is deprecated in PHP 5.3 and greater in Unknown on line 0
[Tue Mar 02 18:21:34 2010] [notice] Digest: generating secret for digest authentication ...
[Tue Mar 02 18:21:34 2010] [notice] Digest: done
[Tue Mar 02 18:21:35 2010] [notice] Apache/2.2.14 (Win32) DAV/2 mod_ssl/2.2.14 OpenSSL/0.9.8l mod_autoindex_color PHP/5.3.1 mod_apreq2-20090110/2.7.1 mod_perl/2.0.4 Perl/v5.10.1 configured -- resuming normal operations
[Tue Mar 02 18:21:35 2010] [notice] Server built: Nov 11 2009 14:29:03
[Tue Mar 02 18:21:35 2010] [notice] Parent: Created child process 1201036
[Tue Mar 02 18:21:35 2010] [warn] module cgi_module is already loaded, skipping
[Tue Mar 02 18:21:35 2010] [warn] NameVirtualHost *:80 has no VirtualHosts
[Tue Mar 02 18:21:36 2010] [warn] module cgi_module is already loaded, skipping
[Tue Mar 02 18:21:36 2010] [warn] NameVirtualHost *:80 has no VirtualHosts
PHP Warning: Directive 'magic_quotes_gpc' is deprecated in PHP 5.3 and greater in Unknown on line 0
[Tue Mar 02 18:21:37 2010] [notice] Digest: generating secret for digest authentication ...
[Tue Mar 02 18:21:37 2010] [notice] Digest: done
[Tue Mar 02 18:21:38 2010] [notice] Child 1201036: Child process is running
[Tue Mar 02 18:21:38 2010] [notice] Child 1201036: Acquired the start mutex.
[Tue Mar 02 18:21:38 2010] [notice] Child 1201036: Starting 150 worker threads.
[Tue Mar 02 18:21:38 2010] [notice] Child 1201036: Starting thread to listen on port 443.
[Tue Mar 02 18:21:38 2010] [notice] Child 1201036: Starting thread to listen on port 80.
[Tue Mar 02 18:21:42 2010] [error] [client 127.0.0.1] Request exceeded the limit of 10 internal redirects due to probable configuration error. Use 'LimitInternalRecursion' to increase the limit if necessary. Use 'LogLevel debug' to get a backtrace., referer: http://localhost/redmine/public/
[Tue Mar 02 18:21:42 2010] [error] [client 127.0.0.1] Request exceeded the limit of 10 internal redirects due to probable configuration error. Use 'LimitInternalRecursion' to increase the limit if necessary. Use 'LogLevel debug' to get a backtrace., referer: http://localhost/redmine/public/

RE: How may i use redmine on my Xampp server? - Added by Prince Shahnawaz almost 13 years ago

After trying serveral attempt, we are facing following errors

[Tue Mar 02 18:57:03 2010] [warn] NameVirtualHost *:80 has no VirtualHosts
[Tue Mar 02 18:57:04 2010] [warn] NameVirtualHost *:80 has no VirtualHosts
PHP Warning: Directive 'magic_quotes_gpc' is deprecated in PHP 5.3 and greater in Unknown on line 0
[Tue Mar 02 18:57:05 2010] [notice] Digest: generating secret for digest authentication ...
[Tue Mar 02 18:57:05 2010] [notice] Digest: done
[Tue Mar 02 18:57:06 2010] [notice] Apache/2.2.14 (Win32) DAV/2 mod_fastcgi/mod_fastcgi-SNAP-0811090952 mod_ssl/2.2.14 OpenSSL/0.9.8l mod_autoindex_color PHP/5.3.1 mod_apreq2-20090110/2.7.1 mod_perl/2.0.4 Perl/v5.10.1 configured -- resuming normal operations
[Tue Mar 02 18:57:06 2010] [notice] Server built: Nov 11 2009 14:29:03
[Tue Mar 02 18:57:06 2010] [notice] Parent: Created child process 654696
[Tue Mar 02 18:57:06 2010] [warn] NameVirtualHost *:80 has no VirtualHosts
[Tue Mar 02 18:57:07 2010] [warn] NameVirtualHost *:80 has no VirtualHosts
PHP Warning: Directive 'magic_quotes_gpc' is deprecated in PHP 5.3 and greater in Unknown on line 0
[Tue Mar 02 18:57:08 2010] [notice] Digest: generating secret for digest authentication ...
[Tue Mar 02 18:57:08 2010] [notice] Digest: done
[Tue Mar 02 18:57:08 2010] [notice] Child 654696: Child process is running
[Tue Mar 02 18:57:08 2010] [notice] FastCGI: process manager initialized
[Tue Mar 02 18:57:08 2010] [notice] Child 654696: Acquired the start mutex.
[Tue Mar 02 18:57:08 2010] [notice] Child 654696: Starting 150 worker threads.
[Tue Mar 02 18:57:08 2010] [notice] Child 654696: Starting thread to listen on port 443.
[Tue Mar 02 18:57:08 2010] [notice] Child 654696: Starting thread to listen on port 80.
[Tue Mar 02 18:57:08 2010] [crit] (OS 3)El sistema no puede hallar la ruta especificada. : FastCGI: can't start (dynamic) server "C:/tools/xampp/htdocs/redmine/public/dispatch.fcgi": spawn_fs_process() failed
[Tue Mar 02 18:57:13 2010] [alert] [client 127.0.0.1] FastCGI: failed to connect to (dynamic) server "C:/tools/xampp/htdocs/redmine/public/dispatch.fcgi": something is seriously wrong, any chance the socket/named_pipe directory was removed?, see the FastCgiIpcDir directive
[Tue Mar 02 18:57:13 2010] [error] [client 127.0.0.1] FastCGI: incomplete headers (0 bytes) received from server "C:/tools/xampp/htdocs/redmine/public/dispatch.fcgi"
[Tue Mar 02 18:57:13 2010] [crit] (OS 3)El sistema no puede hallar la ruta especificada. : FastCGI: can't start (dynamic) server "C:/tools/xampp/htdocs/redmine/public/dispatch.fcgi": spawn_fs_process() failed
[Tue Mar 02 18:57:18 2010] [alert] [client 127.0.0.1] FastCGI: failed to connect to (dynamic) server "C:/tools/xampp/htdocs/redmine/public/dispatch.fcgi": something is seriously wrong, any chance the socket/named_pipe directory was removed?, see the FastCgiIpcDir directive
[Tue Mar 02 18:57:18 2010] [error] [client 127.0.0.1] FastCGI: incomplete headers (0 bytes) received from server "C:/tools/xampp/htdocs/redmine/public/dispatch.fcgi"
[Tue Mar 02 18:57:18 2010] [crit] (OS 3)El sistema no puede hallar la ruta especificada. : FastCGI: can't start (dynamic) server "C:/tools/xampp/htdocs/redmine/public/dispatch.fcgi": spawn_fs_process() failed

RE: How may i use redmine on my Xampp server? - Added by Jeffrey Jones almost 13 years ago

You are still using FCGI, try mongrel on its own then try apache+mongrel using the guide I linked to above.

(1-11/11)