redmine2.3 stable send email error

Added by colin yu almost 7 years ago

os:centos5
ruby:1.8.3

An error occurred when i add "enable_starttls_auto: false" to email settings.

i have no idea to fix this problem,anybody can help me pls?

Web application could not be started
exit (SystemExit)
/var/www/redmine/2.3-stable/lib/redmine/configuration.rb:88:in `exit'
/var/www/redmine/2.3-stable/lib/redmine/configuration.rb:88:in `load_from_yaml'
/var/www/redmine/2.3-stable/lib/redmine/configuration.rb:42:in `load'
/var/www/redmine/2.3-stable/lib/redmine/configuration.rb:66:in `[]'
/var/www/redmine/2.3-stable/lib/redmine/thumbnail.rb:24
/usr/local/lib/ruby/gems/1.8/gems/activesupport-3.2.13/lib/active_support/dependencies.rb:251:in `require'
/usr/local/lib/ruby/gems/1.8/gems/activesupport-3.2.13/lib/active_support/dependencies.rb:251:in `require'
/usr/local/lib/ruby/gems/1.8/gems/activesupport-3.2.13/lib/active_support/dependencies.rb:236:in `load_dependency'
/usr/local/lib/ruby/gems/1.8/gems/activesupport-3.2.13/lib/active_support/dependencies.rb:251:in `require'
/var/www/redmine/2.3-stable/lib/redmine.rb:42
/usr/local/lib/ruby/gems/1.8/gems/activesupport-3.2.13/lib/active_support/dependencies.rb:251:in `require'
/usr/local/lib/ruby/gems/1.8/gems/activesupport-3.2.13/lib/active_support/dependencies.rb:251:in `require'
/usr/local/lib/ruby/gems/1.8/gems/activesupport-3.2.13/lib/active_support/dependencies.rb:236:in `load_dependency'

Replies (7)

RE: redmine2.3 stable send email error - Added by Jan Niggemann (redmine.org team member) almost 7 years ago

Your version of ruby is not supported, you need at least 1.8.7, see RedmineInstall for prerequisites

RE: redmine2.3 stable send email error - Added by colin yu almost 7 years ago

Jan Niggemann wrote:

Your version of ruby is not supported, you need at least 1.8.7, see RedmineInstall for prerequisites

  1. ruby -v
    ruby 1.8.7 (2011-06-30 patchlevel 352) [i686-linux]

still fail like before.

RE: redmine2.3 stable send email error - Added by Jan Niggemann (redmine.org team member) almost 7 years ago

Please post all information according to the post How to request help and please post your configuration.yml, too.

RE: redmine2.3 stable send email error - Added by colin yu almost 7 years ago

tks Jan.
it's messed when i update my ruby to 1.9.3.
i copyed a new configuration.yml from the example file.

Permission denied - /.passenger (Errno::EACCES)
/usr/local/lib/ruby/1.9.1/fileutils.rb:247:in `mkdir'
/usr/local/lib/ruby/1.9.1/fileutils.rb:247:in `fu_mkdir'
/usr/local/lib/ruby/1.9.1/fileutils.rb:221:in `block (2 levels) in mkdir_p'
/usr/local/lib/ruby/1.9.1/fileutils.rb:219:in `reverse_each'
/usr/local/lib/ruby/1.9.1/fileutils.rb:219:in `block in mkdir_p'
/usr/local/lib/ruby/1.9.1/fileutils.rb:205:in `each'
/usr/local/lib/ruby/1.9.1/fileutils.rb:205:in `mkdir_p'
/usr/local/lib/ruby/gems/1.8/gems/passenger-4.0.5/lib/phusion_passenger/native_support.rb:145:in `mkdir'
/usr/local/lib/ruby/gems/1.8/gems/passenger-4.0.5/lib/phusion_passenger/native_support.rb:162:in `block in compile'
/usr/local/lib/ruby/gems/1.8/gems/passenger-4.0.5/lib/phusion_passenger/native_support.rb:160:in `each'
/usr/local/lib/ruby/gems/1.8/gems/passenger-4.0.5/lib/phusion_passenger/native_support.rb:160:in `each_with_index'
/usr/local/lib/ruby/gems/1.8/gems/passenger-4.0.5/lib/phusion_passenger/native_support.rb:160:in `compile'
/usr/local/lib/ruby/gems/1.8/gems/passenger-4.0.5/lib/phusion_passenger/native_support.rb:138:in `compile_and_load'
/usr/local/lib/ruby/gems/1.8/gems/passenger-4.0.5/lib/phusion_passenger/native_support.rb:37:in `start'
/usr/local/lib/ruby/gems/1.8/gems/passenger-4.0.5/lib/phusion_passenger/native_support.rb:205:in `<top (required)>'
/usr/local/lib/ruby/1.9.1/rubygems/custom_require.rb:36:in `require'
/usr/local/lib/ruby/1.9.1/rubygems/custom_require.rb:36:in `require'
/usr/local/lib/ruby/gems/1.8/gems/passenger-4.0.5/helper-scripts/rack-preloader.rb:48:in `init_passenger'
/usr/local/lib/ruby/gems/1.8/gems/passenger-4.0.5/helper-scripts/rack-preloader.rb:126:in `<module:App>'
/usr/local/lib/ruby/gems/1.8/gems/passenger-4.0.5/helper-scripts/rack-preloader.rb:6:in `<module:PhusionPassenger>'
/usr/local/lib/ruby/gems/1.8/gems/passenger-4.0.5/helper-scripts/rack-preloader.rb:5:in `<main>'
Application root
/var/www/redmine/2.3-stable

RE: redmine2.3 stable send email error - Added by colin yu almost 7 years ago

it's worked before update passenger for ruby 1.9.1.

RE: redmine2.3 stable send email error - Added by Jan Niggemann (redmine.org team member) almost 7 years ago

You must have messed up permissions, read the first line of your trace:

Permission denied - /.passenger (Errno::EACCES)

Try to get that fixed and then we'll see what to do next.

RE: redmine2.3 stable send email error - Added by Paresh Patel almost 7 years ago

hi,

this below setting configure your configuration.yml file
then restart your redmine working email is started.....

production:
delivery_method: :sendmail
smtp_settings:
address: 127.0.0.1
port: 25
domain: yourdomainname.com
user_name: ""
password: "*********"

Thanks,
Paresh.Patel

(1-7/7)