[FIXED] How to use the new 1.3.0 'Assign to Group' feature?

Added by Deoren Moor over 8 years ago

So, I created a new group, assigned two users to it and went into a project where the group (and it's members) have Manager access. I tried to create a new ticket and went to assign to this new group, but the group was not listed; Only the individuals were.

What am I missing?

Thanks.

Replies (7)

RE: How to use the new 1.3.0 'Assign to Group' feature? - Added by Jean-Philippe Lang over 8 years ago

Go to application settings -> issue tracking -> enable group assignment and make sure your group has an assignable role.

RE: How to use the new 1.3.0 'Assign to Group' feature? - Added by Deoren Moor over 8 years ago

Thanks for the feedback. I looked, but I don't see that option. I have version Redmine 1.3.0.stable.8180 installed.

I went to:

Administration -> Settings -> Issue Tracking

and I only see the options listed in topic_27898_missing_group_assignment_option.png

topic_27898_missing_group_assignment_option.png - Missing group assignment option (42.3 KB)

RE: How to use the new 1.3.0 'Assign to Group' feature? - Added by Etienne Massip over 8 years ago

This does not look like a 1.3 settings screen?!

RE: How to use the new 1.3.0 'Assign to Group' feature? - Added by Jean-Philippe Lang over 8 years ago

This is definitely not a 1.3 settings screen. Here is how it looks like:

settings_1.3.png (9.07 KB)

RE: How to use the new 1.3.0 'Assign to Group' feature? - Added by Deoren Moor over 8 years ago

Thanks for the feedback.

Here is what I did to upgrade from 1.2.2 to 1.3.0:

cd /opt/redmine
svn sw http://redmine.rubyforge.org/svn/tags/1.3.0
rake db:migrate RAILS_ENV=production
rake tmp:cache:clear
rake tmp:sessions:clear
chown -R www-data .

That is what I've done in the past and I've been able to successfully upgrade between versions.

  • Did I overlook something?
  • Can you confirm that version 1.3 is tagged correctly?
svn info
Path: .
URL: http://redmine.rubyforge.org/svn/tags/1.3.0
Repository Root: http://redmine.rubyforge.org/svn
Repository UUID: e93f8b46-1217-0410-a6f0-8f06a7374b81
Revision: 8191
Node Kind: directory
Schedule: normal
Last Changed Author: jplang
Last Changed Rev: 8180
Last Changed Date: 2011-12-10 08:50:59 -0600 (Sat, 10 Dec 2011)

Thanks for your help.

RE: How to use the new 1.3.0 'Assign to Group' feature? - Added by Jean-Philippe Lang over 8 years ago

1.3.0 is tagged correctly. You can see the new setting in the view:
source:/tags/1.3.0/app/views/settings/_issues.html.erb

Did you restart your Redmine instance? Just in case...

RE: How to use the new 1.3.0 'Assign to Group' feature? - Added by Deoren Moor over 8 years ago

Jean-Philippe Lang wrote:

Did you restart your Redmine instance? Just in case...

Doh! I feel so stupid. It turns out that I issued the restart command, but Nginx didn't do so (even killall nginx didn't work). I ended up rebooting the server to force it to restart.

Thanks for your help on this, I appreciate it!

(1-7/7)