What version of Rails should I install for Redmine 1.3.3?

Added by Lawrence Krubner over 8 years ago

We decided to downgrade from Redmine 2.2 to Redmine 1.3.3. There are some old plugins that we want.

I am having trouble finding installation instructions for Redmine 1.3. Does anyone know what version of Ruby and Rails it expects?

Replies (9)

RE: What version of Rails should I install for Redmine 1.3.3? - Added by Jan Niggemann (redmine.org team member) over 8 years ago

History 148 if Redmine Install: http://www.redmine.org/projects/redmine/wiki/RedmineInstall/148
For the record: You need versions of ruby and rails that have serious security bugs, we recommend to not use outdated versions.

RE: What version of Rails should I install for Redmine 1.3.3? - Added by Mischa The Evil over 8 years ago

You can also check the INSTALL document in the source: source:/tags/1.3.3/doc/INSTALL.

Though, I endorse the statement made by Jan about using outdated, unsupported and vulnerable stack components (including an old and unsupported Redmine release itself).

RE: What version of Rails should I install for Redmine 1.3.3? - Added by Lawrence Krubner over 8 years ago

Sadly, we tried to upgrade to Redmine 2.2, but found that almost all of the plugins that we rely on have been abandoned. I made a small attempt to fix some of the plugins, but the amount of necessary work turned out to be far more than my company was willing to invest. So we had to give up on 2.2. So now we are trying 1.3.3.

RE: What version of Rails should I install for Redmine 1.3.3? - Added by Mischa The Evil over 8 years ago

Lawrence Krubner wrote:

[...] but found that almost all of the plugins that we rely on have been abandoned.

Can you provide a list of these plugins? Lots of old plugins have forks which are/were made compatible with recent Redmine releases and are maintained by community members. Besides that, maybe someone will pick up one or more if they read along...

[...] So we had to give up on 2.2. So now we are trying 1.3.3.

So you upgraded a 1.x.x instance to 2.2.x and now want to downgrade back to 1.3.3? I guess specifically 1.3.3 because that's the last 1.3.x release, whereas 1.4.x releases are starting to break plugin compatibility?

It can't be said enough: make absolutely sure that this Redmine instance is running on local lan only, behind a properly configured firewall (and without people as users who might have bad intentions ;).

RE: What version of Rails should I install for Redmine 1.3.3? - Added by Lawrence Krubner over 8 years ago

On a dev server we got Redmine working as version 2.2. But we never switched over because we could not get the plugins to work. We continued to use our 1.2 Redmine as our production ticket/wiki system. And now, on a different, dev server, we created an image of the 1.2 Redmine server, and that is what I am now upgrading to version 1.3.3.

Our Redmine instance sits on our local network -- no one from the outside world can possibly reached that server. You have to be at one of our offices, or tunnel in via VPN, to get to that server.

As to the plugins, I am uploading a screenshot.

RE: What version of Rails should I install for Redmine 1.3.3? - Added by Mischa The Evil over 8 years ago

Lawrence Krubner wrote:

On a dev server we got Redmine working as version 2.2. But we never switched over because we could not get the plugins to work. [...]

Ok, I see.

As to the plugins, I am uploading a screenshot.

That screenshot shows only three third-party plugins which are not supplied/managed by the Redmine core:
  • redmine_backlogs
  • redmine_close_button
  • redmine_lightbox

The vendored gems (in /vendor/gems) were unvendored and brought under bundler control or dropped/obsoleted. The other plugins in /vendor/plugins (some part of the Redmine core) were dropped/obsoleted, moved to /lib/plugins or unvendored and brought under bundler control.

As for redmine_backlogs: according to http://www.redminebacklogs.net/ v1.0.4 is compatible with 2.2.4.
As for redmine_close_button: according to https://github.com/Undev/redmine_close_button/network 2.2.x and 2.3.x forks exists.
As for redmine_lightbox: according to https://github.com/zipme/redmine_lightbox/commits/master it should be compatible with 2.x releases, besides several active forks exists.

RE: What version of Rails should I install for Redmine 1.3.3? - Added by Jan Niggemann (redmine.org team member) over 8 years ago

Lawrence Krubner wrote:

So now we are trying 1.3.3.
Our Redmine instance sits on our local network -- no one from the outside world can possibly reached that server. You have to be at one of our offices, or tunnel in via VPN, to get to that server.

More than half of all cyber attacks originate from the inside of a company or organization (don't have the link at hand right now)...
Edit: It wasn't this one I had in mind, but 80 Percent of Security Attacks Come From the Inside

(1-9/9)