Project

General

Profile

Actions

Feature #12295

closed

Multilanguage support for custom fields

Added by Daniel Felix over 11 years ago. Updated over 7 years ago.

Status:
Closed
Priority:
Normal
Assignee:
-
Category:
I18n
Target version:
-
Start date:
Due date:
% Done:

0%

Estimated time:
Resolution:
Duplicate

Description

Hi there,

it would be great to have some multilanguage support for custom field through.

Currently, if I'm using one redmine installation for my product which has 3 countrys with 3 different support-hotlines, I need to define my custom fields in 3 languages and associate them to three single projects.

If I could have the abbility to translate every custom field, it would be possible to create one project, with each custom field as single defined field with different translations, which would be identified by the userpreferences.

If no translation is found, the server should take the english translation (for example if french isn't defined, just take english).
The other option would be to define the custom field name as default translation, and add different translations per language.

Just one example.
Custom field: Customer (free text, used as default if no other language translation is found.
Translation for this field:
EN: Customer
DE: Kunde
FR: NIL

If some customer selects the new ticket field and has the preference de, he just sees "Kunde". If he selects new ticket with fr as prefrence, he get's the default - nontranslated custom field name - "Customer".

In my opinion, this would be very helpful to create a realy full l18n support in Redmine!

What do you think about this?


Related issues

Is duplicate of Redmine - Feature #3972: Translation for field valuesNew2009-10-05

Actions
Has duplicate Redmine - Feature #1631: Translation of Custom FieldsClosed2008-07-13

Actions
Actions #1

Updated by fangzheng (方正) over 11 years ago

+1

although not all project creators would like to translate every custom field. :)

Actions #2

Updated by Artur M over 11 years ago

fangzheng (方正) wrote:

+1

although not all project creators would like to translate every custom field. :)

Most Redmine administrators need to translate custom fields.

Actions #3

Updated by billy chou about 11 years ago

Artur M wrote:

fangzheng (方正) wrote:

+1

although not all project creators would like to translate every custom field. :)

Most Redmine administrators need to translate custom fields.

+1

Actions #4

Updated by Maxim Krušina over 10 years ago

+1

Actions #5

Updated by Thomas Bieth almost 10 years ago

I am facing same issue on our instance. We are working with an offshoring development / coding team and clients are located in Germany. Not all clients do like or understand English in Germany.
Coders and internal staff can handle English but translation would be smart and helpful.

Actions #6

Updated by Toshi MARUYAMA over 9 years ago

  • Related to deleted (Feature #3972: Translation for field values)
Actions #7

Updated by Toshi MARUYAMA over 9 years ago

  • Status changed from New to Closed
  • Resolution set to Duplicate

Duplicate of #3972.

Actions #8

Updated by Toshi MARUYAMA over 9 years ago

  • Is duplicate of Feature #3972: Translation for field values added
Actions #9

Updated by Kamil Franckiewicz over 8 years ago

+1

Actions #10

Updated by Toshi MARUYAMA over 8 years ago

  • Has duplicate Feature #1631: Translation of Custom Fields added
Actions #11

Updated by Anton Hedström over 7 years ago

+1

Actions

Also available in: Atom PDF