Feature #3972

Translation for field values

Added by Martin G about 8 years ago. Updated 2 months ago.

Status:NewStart date:2009-10-05
Priority:NormalDue date:
Assignee:-% Done:

0%

Category:I18n
Target version:-
Resolution:

Description

It would be very nice when the values of fields can be translated in different languages. For example:
1st user has choose language english -> So he see the ticket status "new" to choose
2nd user has choose language german -> So he see the ticket status "neu" to choose

localizable.zip (5.23 KB) Martin G, 2013-02-19 07:49

localizable-Rails-4.2.patch Magnifier - Rails 4.2 compatibility changes (1.91 KB) Olivier Houdas, 2015-05-09 10:02


Related issues

Related to Redmine - Defect #4668: Localisation issue : trackers / status are not localisable Closed 2010-01-27
Related to Redmine - Feature #4886: Name of custom fields should be multilingual New
Duplicated by Redmine - Feature #6040: Translation custom fields, issue status, activities..... Closed 2010-08-05
Duplicated by Redmine - Defect #7113: Status, priority, tracker are not multilanguage Closed 2010-12-15
Duplicated by Redmine - Feature #15575: Multi language tracker name Closed
Duplicated by Redmine - Feature #12295: Multilanguage support for custom fields Closed
Duplicated by Redmine - Feature #11964: Translate-able custom captions Closed
Duplicated by Redmine - Feature #16250: Multilanguage Closed
Duplicated by Redmine - Feature #27234: I need put the custom fields lavel in multiple language Closed

History

#1 Updated by Stéphane Allemand about 8 years ago

I am very interested by this ticket, because on our team we have beta tester who are Holland, Spain, German, French And english.....

Or could you explain us a way to translate this kind of values.

#2 Updated by Andreas Hartmann about 8 years ago

Interestingly, the I18n catalogues contain the corresponding messages:

default_issue_status_new: Neu
default_issue_status_assigned: Zugewiesen
default_issue_status_resolved: Gelöst
default_issue_status_feedback: Feedback
default_issue_status_closed: Erledigt
default_issue_status_rejected: Abgewiesen

#3 Updated by Andreas Hartmann about 8 years ago

Andreas Hartmann wrote:

Interestingly, the I18n catalogues contain the corresponding messages:

I guess the problem is that it is hard to support generic (translated) and user-defined status names at the same time. The table would have to contain an extra column to determine if the status name is an i18n key, i.e. should be translated, or is a user-defined name.

#4 Updated by Jean-Philippe Lang almost 7 years ago

  • Category changed from Translations to I18n
  • Assignee deleted (Azamat Hackimov)

#5 Updated by Luis Serrano Aranda almost 7 years ago

This plugin makes the translation and works http://ociotec.com/redmine/projects/localizable

#6 Updated by Martin G almost 7 years ago

Luis Serrano Aranda wrote:

This plugin makes the translation and works http://ociotec.com/redmine/projects/localizable

Thank you for this info. It works perfect!

#7 Updated by Artur M almost 5 years ago

Martin G wrote:

Luis Serrano Aranda wrote:

This plugin makes the translation and works http://ociotec.com/redmine/projects/localizable

Thank you for this info. It works perfect!

Not available for Redmine 2.*

#8 Updated by Martin G almost 5 years ago

This one will work with 2.2.x

#9 Updated by Olivier Houdas over 4 years ago

I could not make it work on Redmine 2.3.1.stable :
  • first, I got an error in app/views/settings/_localizable.html.erb, line 54: {:name => "enumeration", :objects => Enumeration.find(:all, :conditions => "project_id IS NULL").sort{|a, b| a.type.downcase <=> b.type.downcase}
    because it does not like to have "type" as a column name
  • second, it could not find en.general_lang_name
  • third, when I translated some strings, it put all my "localized" pages in error, and i the log, I found "ActionView::Template::Error (translation missing: en.date.formats.default):"

Anyway, I think Redmine should not need a plugin for providing a way to localize custom value names.

#10 Updated by Bruno Medeiros about 4 years ago

I would be very happy to see this implemented.

#11 Updated by Maxim Krušina about 4 years ago

+1

#12 Updated by Olivier Houdas about 4 years ago

Update: I finally have gotten it to work with the files attached. We're now using Redmine 2.3.3-stable.
The first issues I faced were probably caused by another plugin (wrong translation file headers resulting in random errors).

#13 Updated by Toshi MARUYAMA almost 4 years ago

#14 Updated by Kevin Palm about 3 years ago

+1

#15 Updated by Fabian Strasser about 3 years ago

Please make this more important. There are many tickets out there that aim at the same problem all over Redmine, yet nothing seems to be considered. Why? This would enrich this great piece of software another great deal!

Tickets related to this issue:

#4668
#4844
#4886
#5523
#5990
#6040
#7113
#8058
#12295
#15575

and possibly many more. Yes, there are duplicates, but those only show that this is important to the users!

#16 Updated by Toshi MARUYAMA about 3 years ago

  • Related to deleted (Feature #12295: Multilanguage support for custom fields)

#17 Updated by Toshi MARUYAMA about 3 years ago

  • Duplicated by Feature #12295: Multilanguage support for custom fields added

#18 Updated by Ralf S. almost 3 years ago

+1

A general method to support multilingual custom fields (as in #4886) would be very worthfull! (e.g. for PDF exports in the requiered language)

#19 Updated by dominik ch almost 3 years ago

+1
why is such important feature missing? :(

#20 Updated by Maxim Krušina over 2 years ago

+1

#21 Updated by Slawomir CALUCH over 2 years ago

+1

Surprisingly this is an important issue for some users.

I have non english users who are completely lost with the interface due to non obvious english trackers and custom fields.

Any news on translatable tracker and custom fields?

#22 Updated by Daniel Tamajon over 2 years ago

Has anyone tested the localizable project referenced on #8 (http://www.redmine.org/plugins/localizable) on 2.6.x version? I don't get it working.

#23 Updated by Daniel Tamajon over 2 years ago

Sorry... I didn't installed properly... just my fault.

#24 Updated by Olivier Houdas over 2 years ago

And if someone wants to use it with Redmine 3.0 (-> Rails 4.2), here is a patch to apply (5 lines changed in one file).

#25 Updated by Florian ROBERT almost 2 years ago

+1

#26 Updated by Anton Jakimovic almost 2 years ago

Redmine localization plugin is outdated, so this issue is important to me. Actually I can't upgrade because of that.

+1

#27 Updated by Shinji Tamura 10 months ago

+1

This is very useful plugin. But this plugin can't translate list values of custom field. Do you know any plugin be able to translate list values of custom field?

#28 Updated by Go MAEDA 10 months ago

#29 Updated by Go MAEDA 10 months ago

#30 Updated by Ilya Ternovoy 2 months ago

Our team now facing the same problem.
At least would be great to make an opportunity to translate next fields:
1. priority
2. statuses
3. actions
Now all fields in Russian, but we need to give access to our redmine for our US customer

UPD: It seems like http://www.redmine.org/plugins/localizable works great! I have redmine 3.3.

Steps:
  1. Download last version from https://redmine.ociotec.com/projects/localizable/files.
  2. Unzip on your Redmine folder /plugins.
  3. Rename the folder from localizable.x.y.z to localizable.
  4. No migration is needed.
  5. Restart you Redmine.
  6. Once installed, go to Administration, plugins and click on Configuration link on this plugin.
  7. Choose necessary languages and press apply, then put the translations in text fields.

#31 Updated by Toshi MARUYAMA about 1 month ago

  • Duplicated by Feature #27234: I need put the custom fields lavel in multiple language added

Also available in: Atom PDF