Defect #16784

Notifications not sent when receiving emails with rake task and async deliveries

Added by JEREMY LEGRAND over 4 years ago. Updated 11 days ago.

Status:ClosedStart date:
Priority:NormalDue date:
Assignee:Jean-Philippe Lang% Done:

0%

Category:Email notifications
Target version:-
Resolution:Wont fix Affected version:2.5.0

Description

Hi all,

I just installed redmine 2.5.0 and my all team is glad to use it.
I tried to allow issue creation by email from our clients.
The clients will send an email to a specific email address which be fetch by redmine.
So our clients do not have access to Redmine.
It's works very well with receive_imap parameter and unknown_users=1.

The problem is the project maanger does not receive a notification of new issue created by our clients.
If I create an issue from the redmine interface, the notification worked.

My SMTP settings are async_smtp with gmail account.

Thanks for your help !

rev13123.patch Magnifier (1.49 KB) Toshi MARUYAMA, 2014-05-02 16:33


Related issues

Related to Redmine - Feature #26791: Send individual notification mails per mail recipient Closed

Associated revisions

Revision 13123
Added by Jean-Philippe Lang over 4 years ago

Use async email deliveries in rake tasks (#16784).

History

#1 Updated by Jean-Philippe Lang over 4 years ago

  • Status changed from New to Resolved
  • Assignee set to Jean-Philippe Lang
  • Target version set to 2.5.2
  • Resolution set to Fixed

This should be fixed by r13123.

#2 Updated by Jean-Philippe Lang over 4 years ago

  • Subject changed from Email notification from issue created by unknown user to Notifications not sent when receiving emails with rake task and async deliveries

#3 Updated by JEREMY LEGRAND over 4 years ago

Hi,

I updated the file email.rake and the notifications still don't work.
I restarted all my server, I use "bundle install" command.
I saw you changed the target version to 2.5.2. That's means others fixes are needed for my defect ?

Many thanks for your contribution Jean-Philippe.

#4 Updated by Toshi MARUYAMA over 4 years ago

r13123 have not merged to 2.5-stable yet.
Try this patch to your Redmine.

#5 Updated by JEREMY LEGRAND over 4 years ago

I downloaded the file from the revision : http://www.redmine.org/projects/redmine/repository/revisions/13123/entry/trunk/lib/tasks/email.rake and ovverrided my file.
I check your patch, my email.rake file seems to be correct.

Unfortunately, notifications from unknown_users by rake still don't work.
It's the last feature wanted by my team before go-live with our clients.
I really hope that the next version of Redmine will work on this specific feature.

Kind regards,

#6 Updated by Toshi MARUYAMA over 4 years ago

  • Status changed from Resolved to New
  • Resolution deleted (Fixed)

#7 Updated by Jean-Philippe Lang over 4 years ago

  • Target version changed from 2.5.2 to Candidate for next minor release

#8 Updated by Go MAEDA 2 months ago

  • Related to Feature #26791: Send individual notification mails per mail recipient added

#9 Updated by Go MAEDA 11 days ago

  • Status changed from New to Closed
  • Target version deleted (Candidate for next minor release)
  • Resolution set to Wont fix

In Redmine 4.0, the async_smtp setting is obsolete and emails are delivered asynchronously by default.

Also available in: Atom PDF