Feature #19965

values of custom fileds of version type should be prefixed with or grouped by project name

Added by Frederic Cand about 5 years ago. Updated over 3 years ago.

Status:ClosedStart date:
Priority:NormalDue date:
Assignee:-% Done:

0%

Category:Custom fields
Target version:-
Resolution:

Description

Steps to reproduce
  • create projects hierarchy
  • create versions shared with project tree
  • create a custom field attached to issues, type version, attached to a tracker of one of the above project
  • create a new issue
Actual result
  • whereas shared versions are grouped by projects in "target version" field, versions in custom field are flat (if some versions are the same in different projects, they are displayed indistinctly)
Expected result
  • shared versions in custom field should be either prefixed with project name, or grouped by project name; just like for "target version"

Related issues

Related to Redmine - Feature #19966: Related issues displayed on "issues" page should be prefi... New
Related to Redmine - Feature #9850: Differentiate shared versions in version-format custom fi... Closed

History

#1 Updated by Alexis Parent almost 5 years ago

+1

#2 Updated by Toshi MARUYAMA almost 5 years ago

  • Category changed from UI to Custom fields

#3 Updated by Toshi MARUYAMA almost 5 years ago

  • Related to Feature #19966: Related issues displayed on "issues" page should be prefixed by project name added

#4 Updated by BD Garg almost 5 years ago

+1

#5 Updated by Sebastian Paluch almost 5 years ago

+1

#6 Updated by Mischa The Evil almost 5 years ago

This seems to be duplicating #9850 and #9851, right?

#7 Updated by Toshi MARUYAMA almost 5 years ago

  • Related to Feature #9850: Differentiate shared versions in version-format custom field drop-downs by prepending its project name added

#8 Updated by Toshi MARUYAMA almost 5 years ago

  • Related to Feature #9851: Equalize the way how available shared versions are differentiated in target version drop-downs added

#9 Updated by Mischa The Evil over 3 years ago

  • Related to deleted (Feature #9851: Equalize the way how available shared versions are differentiated in target version drop-downs)

#10 Updated by Mischa The Evil over 3 years ago

  • Status changed from New to Closed

This is fixed by r16194 for #23265.

Also available in: Atom PDF