Project

General

Profile

Actions

Defect #22034

closed

Locked users disappear from project settings

Added by Frederico Camara about 8 years ago. Updated almost 7 years ago.

Status:
Closed
Priority:
Normal
Category:
Project settings
Target version:
Start date:
Due date:
% Done:

0%

Estimated time:
Resolution:
Fixed
Affected version:

Description

I control which users are part of my projects, but I'm having problems with locked users. Thay disappear from the list and I can't manage them as long as they're locked. If at anytime they become unlocked by the administrator, thay would unexpectedly show up in my project with roles I gave them months ago.

This is annoying. I don't care if the users disappear from the workflow or from the page project, but if they are locked for some reason in Redmine, I should still be able to change their roles in my project, or kick them out if I needed to.


Files

setting-member.png (27.8 KB) setting-member.png screenshot (before r14332) Go MAEDA, 2016-12-25 14:19
Actions #1

Updated by Frederico Camara about 8 years ago

Patch. Save and:

patch -p1 < ~/22034.patch

diff -ruN redmine-3.2.0/app/views/projects/settings/_members.html.erb redmine/app/views/projects/settings/_members.html.erb
--- redmine-3.2.0/app/views/projects/settings/_members.html.erb    2015-12-06 12:06:20.000000000 -0200
+++ redmine/app/views/projects/settings/_members.html.erb    2016-02-15 12:12:51.284005067 -0200
@@ -1,5 +1,5 @@
 <% roles = Role.find_all_givable
-   members = @project.memberships.active.includes(:member_roles, :roles, :principal).to_a.sort %>
+   members = @project.memberships.includes(:member_roles, :roles, :principal).to_a.sort %>

 <p><%= link_to l(:label_member_new), new_project_membership_path(@project), :remote => true, :class => "icon icon-add" %></p>

Actions #2

Updated by Toshi MARUYAMA about 8 years ago

  • Category set to Project settings
Actions #3

Updated by Go MAEDA about 7 years ago

  • Subject changed from Blocked users disappear from project settings to Locked users disappear from project settings
  • Description updated (diff)
Actions #4

Updated by Go MAEDA about 7 years ago

I think this is a regression caused by r14332.

On Redmine 3.0.x and before, we could see locked user on Settings > Members tab like the following.

r14332)" alt="screenshot (before r14332)" />

Actions #5

Updated by Jean-Philippe Lang about 7 years ago

  • Status changed from New to Resolved
  • Assignee set to Jean-Philippe Lang
  • Resolution set to Fixed

Fixed with tests in r16116. The memberships API is also updated to return locked members.
Thanks for pointing this out.

Actions #6

Updated by Jean-Philippe Lang about 7 years ago

  • Status changed from Resolved to Closed
Actions #7

Updated by VVD VVD about 7 years ago

Just updated from 3.3.1 to 3.3.2 - can't see locked users in Settings > Members tab in both versions.
Can't see in Overview, not in Settings.

Actions #8

Updated by Toshi MARUYAMA about 7 years ago

Go MAEDA wrote:

I think this is a regression caused by r14332.

On Redmine 3.0.x and before, we could see locked user on Settings > Members tab like the following.

r14332)" alt="screenshot (before r14332)" />

Really? I cannot reproduce.

Actions #9

Updated by Toshi MARUYAMA about 7 years ago

VVD VVD wrote:

Just updated from 3.3.1 to 3.3.2 - can't see locked users in Settings > Members tab in both versions.
Can't see in Overview, not in Settings.

What do you expect?

Actions #10

Updated by VVD VVD almost 7 years ago

Toshi MARUYAMA wrote:

VVD VVD wrote:

Just updated from 3.3.1 to 3.3.2 - can't see locked users in Settings > Members tab in both versions.
Can't see in Overview, not in Settings.

What do you expect?

See locked users in Overview too (grey).

Actions #11

Updated by Toshi MARUYAMA almost 7 years ago

VVD VVD wrote:

Toshi MARUYAMA wrote:

VVD VVD wrote:

Just updated from 3.3.1 to 3.3.2 - can't see locked users in Settings > Members tab in both versions.
Can't see in Overview, not in Settings.

What do you expect?

See locked users in Overview too (grey).

Please create new issue if you want.

Actions

Also available in: Atom PDF