Project

General

Profile

Actions

Defect #23019

closed

Markdown doesn't recognize mails

Added by kay rus almost 8 years ago. Updated 4 months ago.

Status:
Closed
Priority:
Normal
Assignee:
-
Category:
Text formatting
Target version:
-
Start date:
Due date:
% Done:

0%

Estimated time:
Resolution:
Wont fix
Affected version:

Description

Redmine hides this email in markdown:

<a_bc@def.com>

But it doesn't hide this:

<abc@def.com>

Files

markdown_emails.png (149 KB) markdown_emails.png Marius BĂLTEANU, 2018-02-09 19:12
Actions #1

Updated by Toshi MARUYAMA almost 8 years ago

  • Category set to Text formatting
Actions #3

Updated by Go MAEDA almost 7 years ago

The latest version of Redcarpet still have this problem (we upgraded Redcarpet to 3.4.0 in r16583).

Actions #4

Updated by Marius BĂLTEANU over 6 years ago

kay rus wrote:

https://github.com/vmg/redcarpet/issues/402

Go MAEDA wrote:

The latest version of Redcarpet still have this problem (we upgraded Redcarpet to 3.4.0 in r16583).

Redmine is not affected by the respective issue because we have no_intra_emphasis: true and the emails with _ are recognised correctly. Please see the below screenshot.

The issue with <a_bc@def.com> looks to be from the same Redcarpet gem, the text is filtered out because it is recognised wrongly as HTML tag.

Rails console:

With :filter_html => true:

irb(main):012:0> Redcarpet::Markdown.new(Redmine::WikiFormatting::Markdown::HTML.new(:filter_html => true, :hard_wrap => true), autolink: true, no_intra_emphasis: true).render("<a_bc@def.com>")
=> "" 

With :filter_html => false:

irb(main):013:0> Redcarpet::Markdown.new(Redmine::WikiFormatting::Markdown::HTML.new(:filter_html => false, :hard_wrap => true), autolink: true, no_intra_emphasis: true).render("<a_bc@def.com>")
=> "<p><a_bc@def.com></p>\n" 

Actions #5

Updated by Go MAEDA 4 months ago

  • Status changed from Confirmed to Closed
  • Resolution set to Wont fix

Using CommonMark Markdown instead of Redcarpet-based Markdown can avoid the issue.

Please switch to CommonMark Markdown. Redcarpet-based Markdown was marked as "deprecated" (#36807) in Redmine 5.1.0 and will be removed in the future version.

Actions

Also available in: Atom PDF