Defect #29226

Email delivery error: 550 Mailbox not found or access denied , there is an invalid email address

Added by li gh about 2 years ago. Updated about 2 years ago.

Status:ClosedStart date:
Priority:NormalDue date:
Assignee:-% Done:

0%

Category:Email notifications
Target version:-
Resolution:Duplicate Affected version:3.4.3

Description

For example:
In a project , members :user1,user2,user3.
user1:
user2:
user3:
When create a news , normally,all users receive a mail notification .
If the is invalid for some reasons , the news will be created successfully, but the mail notification will be failed , all other members (user1,user2) cannot receive the mail.

Log:


Started POST "/news/171/comments" for 10.1.10.22 at 2018-07-12 17:24:49 +0800
Processing by CommentsController#create as HTML
  Parameters: {"utf8"=>"?", "authenticity_token"=>"GmhU0PwvRK39intG3e/pjLKWhMkTTY1IlhdLMLG+DCXSTokSuzB9IZpTvfruV2ay5+Ef5EMKp7CQ0H1MoH8GCw==", "comment"=>{"comments"=>"<p>7+2</p>\r\n"}, "commit"=>"新增", "id"=>"171"}
  Current user: lgh (id=20)
  Rendered mailer/news_comment_added.text.erb within layouts/mailer (0.6ms)
  Rendered mailer/news_comment_added.html.erb within layouts/mailer (1.3ms)
Email delivery error: 550 Mailbox not found or access denied*

Sorry for my poor English, any one get what I mean? >.<!


Related issues

Duplicates Redmine - Defect #8157: Redmine do not send notification emails if a recipients e... Closed

History

#1 Updated by Holger Just about 2 years ago

  • Duplicates Defect #8157: Redmine do not send notification emails if a recipients email address is not valid added

#2 Updated by Holger Just about 2 years ago

  • Status changed from New to Closed
  • Resolution set to Duplicate

The reason for that is that Redmine sends a single notification email to all recipients. If your MTA rejects the mail, it will not be sent at all. You might be able to configure your MTA (postfix, exim, ...) to change this behavior and instruct it to accept mails even for invalid recipients.

In any case, this issue is a duplicate of #8157 and several related issues.

Also available in: Atom PDF