Project

General

Profile

Actions

Defect #8157

closed

Redmine do not send notification emails if a recipients email address is not valid

Added by Martin Schneider over 13 years ago. Updated over 5 years ago.

Status:
Closed
Priority:
Normal
Assignee:
-
Category:
Email notifications
Target version:
Start date:
Due date:
% Done:

0%

Estimated time:
Resolution:
Fixed
Affected version:

Description

Reproduction:
  • Add a user with the name "TestUser" and a misconfigured email address (at my side it was something like ).
  • Let the "TestUser" create a ticket.
Behaviour of Redmine when the newly created ticket is changed:
  • Redmine needs very long to respond (~2 min.).
  • Nobody receives a notification email (e.g. the ticket creator, watchers, everyone with the "For any event on all my projects" email setting).
My Redmine server configuration:
  • MySQL 5.1.41-3ubuntu12.6
  • Ruby 1.8.6
  • Rails 2.3.5
  • Redmine 1.1.0
  • SVN 1.6.12-1406.49 hosted via CollabNet Subversion Edge 1.2.1-1406.49
Additional Information:
  • Our email server is Microsoft Exchange 2003

Fatal side effect of this bug
We do a lot of subtasking. Sometimes when the user with the misconfigured email address adds a ticket into a deep subtask structure this structure will be corrupted!

After a little database analysis I figured out, that the issues.lft and issues.rgt become inconsistent...

PS:
Redmine is pretty cool! We use it since some years and this is the first real problem with it.
Keep on moving ;-)


Related issues

Related to Redmine - Defect #7917: Creating users via email fails if user real name containes special charsClosed2011-03-18

Actions
Related to Redmine - Defect #6829: Emails not sent if server rejects one of the recipientsClosed2010-11-04

Actions
Related to Redmine - Defect #8733: Sending email fails when one of members has illegal characters in email addressClosed2011-07-01

Actions
Related to Redmine - Defect #5163: Rejection of one recipient by the SMTP server causes whole notification to be droppedClosed2010-03-24

Actions
Related to Redmine - Feature #19335: Allow setting user account settings to read-only fields (especially when using LDAP)New

Actions
Related to Redmine - Feature #26791: Send individual notification mails per mail recipientClosedJean-Philippe Lang

Actions
Has duplicate Redmine - Defect #17318: Email Notifications Fails for All Members when One Email is InvalidClosed

Actions
Has duplicate Redmine - Defect #123: One user's bad email address breaks all email notifications for everyone on a projectClosed

Actions
Has duplicate Redmine - Defect #19360: the wrong mail in one of the redmine account will cause all mail stop sendingClosed

Actions
Has duplicate Redmine - Defect #20912: First email notification isn't send to userClosed

Actions
Has duplicate Redmine - Defect #11167: Sending email notification to more than one users fail if one address email is invalidClosed

Actions
Has duplicate Redmine - Defect #29226: Email delivery error: 550 Mailbox not found or access denied , there is an invalid email addressClosed

Actions
Actions #1

Updated by Евгений Золотин over 13 years ago

I have the same problem. Today I've noticed, that notifications from forum were not send. Looking through production.log file I've found the reason: 550 error - unknown accaunt. One of user's account has wrong e-mail, and other users can't recieve e-mail notifications. I've tried to send e-mail to this wrong adress with other good adresess from MS Outlook, and I've recieved the same bug from automatic admin's e-mail: 550 unknown account. But other users with good adresses got my test e-mail. When Redmine do send it's notifications and one of the e-mail adresses is wrong, nobody can recieve notifications. Seems that problem with Redmine.

Actions #2

Updated by Fabien Crespel about 12 years ago

This issue still occurs with Redmine 1.3.3.

When one project member with an invalid email address fails to receive a notification (e.g. 550 Recipient address rejected: User unknown in local recipient table), subsequent notifications are not sent to any other member involved in the issue/project.

As the account involved is a generic account in my case, I disabled all notifications for it. But if for a reason or another a previously valid email address becomes invalid (employee leaving a company...), it will block notifications for everyone else - which I think is a major issue.

Actions #3

Updated by Pieter Smith about 12 years ago

Same problem on our server (Redmine 1.4.2). Also tried to change the Blind carbon copy recipients (bcc) option on the 'Redmine'.'Settings'.'Email notifications' page as a potential workaround, but it has no effect.

Actions #4

Updated by Miodrag Milic almost 11 years ago

The issue is still present

Actions #5

Updated by Miodrag Milic over 10 years ago

Does anybody know some quick fix solution for this in source code ?
For instance parallel sending of mails to each user and so on ?

Actions #6

Updated by James H about 10 years ago

is this still like this?

Actions #7

Updated by Toshi MARUYAMA almost 10 years ago

  • Has duplicate Defect #17318: Email Notifications Fails for All Members when One Email is Invalid added
Actions #8

Updated by Toshi MARUYAMA almost 10 years ago

  • Has duplicate Defect #123: One user's bad email address breaks all email notifications for everyone on a project added
Actions #9

Updated by James H over 9 years ago

+1

Actions #10

Updated by Go MAEDA over 9 years ago

  • Related to Defect #6829: Emails not sent if server rejects one of the recipients added
Actions #11

Updated by Go MAEDA over 9 years ago

  • Related to Defect #8733: Sending email fails when one of members has illegal characters in email address added
Actions #12

Updated by Go MAEDA over 9 years ago

  • Related to Defect #5163: Rejection of one recipient by the SMTP server causes whole notification to be dropped added
Actions #13

Updated by Go MAEDA over 9 years ago

  • Related to Defect #11167: Sending email notification to more than one users fail if one address email is invalid added
Actions #14

Updated by Dariusz Kowalski over 9 years ago

I have the same issue.
In our RM , we are connected do Ldap - there is many separated teams were people go in and go out even often. It is impossible to manage of that and disable each account manually. This is a big problem.
Anybody has solution for that issue?

Actions #15

Updated by James H over 9 years ago

Dariusz Tanner
if you are connected to LDAP, why dont you just let LDAP handle the email addresses so you never have an invalid email address?

but still +1 to this issue. It also can still appear when using LDAP if the information in your LDAP is not correct. But that is a different underlying issue.

Actions #16

Updated by Toshi MARUYAMA over 9 years ago

  • Related to deleted (Defect #6579: Tree hierachy being currupted on multiple submissions of an issue)
Actions #17

Updated by Toshi MARUYAMA over 9 years ago

  • Has duplicate Defect #19360: the wrong mail in one of the redmine account will cause all mail stop sending added
Actions #18

Updated by Toshi MARUYAMA over 9 years ago

  • Related to Feature #19335: Allow setting user account settings to read-only fields (especially when using LDAP) added
Actions #19

Updated by Toshi MARUYAMA almost 9 years ago

It seems Redmine.org has this problem, too.
I watch some forum messages on Redmine.org and I don't get notification.
Issue form have watchers list, but forum message form does not have.

Actions #20

Updated by Toshi MARUYAMA over 8 years ago

  • Has duplicate Defect #20912: First email notification isn't send to user added
Actions #21

Updated by John Simmons about 8 years ago

I know this is getting pretty old, but I'm having this issue as well. I have all of my users set through LDAP, so there's no defective email addresses, but we added some people who have external email addresses, and they login through non-LDAP, and it breaks any project they are added to. So, 99% of my users are @companyA.com, and 1% are @companyB.com, and any project where someone from company B is added, stops sending emails all together.

Actions #22

Updated by Anonymous almost 8 years ago

+1

Just by looking at the list of related issues, this problem apparently has affected many redmine users. Is there any chance that there will be a solution anytime soon?

Actions #23

Updated by Anonymous over 7 years ago

Any updates on this?

Actions #25

Updated by Kenan Dervisevic almost 7 years ago

Hello, does anyone have a solution for this currently?

Actions #26

Updated by Go MAEDA almost 7 years ago

  • Related to deleted (Defect #11167: Sending email notification to more than one users fail if one address email is invalid)
Actions #27

Updated by Go MAEDA almost 7 years ago

  • Has duplicate Defect #11167: Sending email notification to more than one users fail if one address email is invalid added
Actions #28

Updated by Jan from Planio www.plan.io almost 7 years ago

  • Related to Feature #26791: Send individual notification mails per mail recipient added
Actions #29

Updated by Jan from Planio www.plan.io almost 7 years ago

This would be solved by #26791.

Actions #30

Updated by Juan Diego Iannelli over 6 years ago

+1

Actions #31

Updated by Holger Just about 6 years ago

  • Has duplicate Defect #29226: Email delivery error: 550 Mailbox not found or access denied , there is an invalid email address added
Actions #32

Updated by Ken Zalewski almost 6 years ago

This issue has persisted for years, and is now in the current version, 3.4.6.

It has affected us here at the Senate on multiple occasions when an employee leaves the Senate. That employee's email address is disabled/deleted, so any mail sent to that address returns a 550 SMTP error.

This has the end result of preventing ANY notifications from going out on a project where the terminated employee might be a member. This is bad behavior, and it's been reported multiple times by many Redmine users.

I am asking that this issue be prioritized. We depend on email notifications working properly, and we don't want project notifications to stop working just because one member on that project/group has a bad email address.

Actions #33

Updated by Richard Holyoak over 5 years ago

I can confirm this is causing me problems too. If one person leaves the company then no-one receives emails.

Actions #34

Updated by Go MAEDA over 5 years ago

Richard Holyoak wrote:

I can confirm this is causing me problems too. If one person leaves the company then no-one receives emails.

This issue will be resolved in upcoming Redmine 4.0.0. The patch #26791 has already been committed to the repository.

Actions #35

Updated by Go MAEDA over 5 years ago

  • Status changed from New to Closed
  • Assignee deleted (Jean-Philippe Lang)
  • Target version set to 4.0.0
  • Resolution set to Fixed

Fixed by #26791.

Setting the target version to 4.1.0 in order to add this issue to the changelog.

Actions

Also available in: Atom PDF