Defect #29918

Related issues section ignores the date format setting

Added by Go MAEDA 7 months ago. Updated 6 months ago.

Status:ClosedStart date:
Priority:NormalDue date:
Assignee:Jean-Philippe Lang% Done:

0%

Category:UI
Target version:3.4.7
Resolution:Fixed Affected version:3.4.0

Description

Start date and due date in the related issues section are always displayed in the format YYYY-MM-DD regardless of the date format setting.

incorrect-date-format@2x.png (41.2 KB) Go MAEDA, 2018-11-07 08:58


Related issues

Related to Redmine - Feature #3425: View progress bar of related issues Closed 2009-05-27

Associated revisions

Revision 17656
Added by Jean-Philippe Lang 6 months ago

Related issues section ignores the date format setting (#29918).

Patch by Mizuki ISHIKAWA.

Revision 17657
Added by Jean-Philippe Lang 6 months ago

Adds a test for #29918.

Revision 17663
Added by Jean-Philippe Lang 6 months ago

Merged r17656 and r17657 to 3.4-stable (#29918).

History

#1 Updated by Mizuki ISHIKAWA 7 months ago

The following changes should solve the problem.

diff --git a/app/helpers/issues_helper.rb b/app/helpers/issues_helper.rb
index e1e0fc559b..f71eb13b23 100644
--- a/app/helpers/issues_helper.rb
+++ b/app/helpers/issues_helper.rb
@@ -129,8 +129,8 @@ module IssuesHelper
              content_tag('td', check_box_tag("ids[]", other_issue.id, false, :id => nil), :class => 'checkbox') +
              content_tag('td', relation.to_s(@issue) {|other| link_to_issue(other, :project => Setting.cross_project_issue_relations?)}.html_safe, :class => 'subject', :style => 'width: 50%') +
              content_tag('td', other_issue.status, :class => 'status') +
-             content_tag('td', other_issue.start_date, :class => 'start_date') +
-             content_tag('td', other_issue.due_date, :class => 'due_date') +
+             content_tag('td', format_date(other_issue.start_date), :class => 'start_date') +
+             content_tag('td', format_date(other_issue.due_date), :class => 'due_date') +
              content_tag('td', other_issue.disabled_core_fields.include?('done_ratio') ? '' : progress_bar(other_issue.done_ratio), :class=> 'done_ratio') +
              content_tag('td', buttons, :class => 'buttons'),
              :id => "relation-#{relation.id}",

#2 Updated by Go MAEDA 7 months ago

  • Target version set to 4.1.0

LGTM. Setting the target version to 4.1.0.

#3 Updated by Go MAEDA 7 months ago

  • Related to Feature #3425: View progress bar of related issues added

#4 Updated by Go MAEDA 7 months ago

  • Target version changed from 4.1.0 to 3.4.7
  • Affected version set to 3.4.0

format_date was removed in r15981 (#3425).

#5 Updated by Marius BALTEANU 6 months ago

We should add some assertions to source:trunk/test/functional/issues_controller_test.rb#L1215 just to be sure that will not reproduce anymore.

#6 Updated by Jean-Philippe Lang 6 months ago

  • Status changed from New to Resolved
  • Assignee set to Jean-Philippe Lang
  • Resolution set to Fixed

Patch committed, thanks. I also added a test as suggested by Marius.

BTW, in the subtasks list, we display the subject, status, assignee and done ratio. In the related issues list, we display the subject, status, start date, due date and done ratio. Shouldn't we display the same attributes in both lists?

#7 Updated by Jean-Philippe Lang 6 months ago

  • Status changed from Resolved to Closed

#8 Updated by Marius BALTEANU 6 months ago

Jean-Philippe Lang wrote:

BTW, in the subtasks list, we display the subject, status, assignee and done ratio. In the related issues list, we display the subject, status, start date, due date and done ratio. Shouldn't we display the same attributes in both lists?

Indeed, could be an improvement, but I think that it'll be better to make the attributes configurable because the use cases and the relevant information depends from instance to instance. For example, in my production environment, we modified the view in order to show the subject, status, assignee, estimated and spent because we do not use done ratio, start date and due date. Also, other users requested this, please see #11969 and #5130.

Also available in: Atom PDF