Defect #30370

No validation when adding watcher who is not in this project

Added by Alex Tim 5 months ago. Updated 4 months ago.

Status:ClosedStart date:
Priority:NormalDue date:
Assignee:-% Done:

0%

Category:Issues
Target version:-
Resolution:Wont fix Affected version:

Description

  1. No validation when adding watcher who is not in this project
  2. When adding watcher to several issues from different projects, all users are displayed and can be added.

2.png (17.9 KB) Alex Tim, 2019-01-10 10:19

1.png (54 KB) Alex Tim, 2019-01-10 10:19

3.png (5.4 KB) Alex Tim, 2019-01-10 10:19


Related issues

Related to Redmine - Feature #5159: Ability to add Non-Member watchers to the watch list Closed 2010-03-23
Related to Redmine - Patch #16133: Available watchers on new issue form include users who ca... New

History

#1 Updated by Go MAEDA 4 months ago

  • Related to Feature #5159: Ability to add Non-Member watchers to the watch list added

#2 Updated by Go MAEDA 4 months ago

  • Related to Patch #16133: Available watchers on new issue form include users who cannot even view issues added

#3 Updated by Go MAEDA 4 months ago

  • Status changed from New to Closed
  • Resolution set to Wont fix

It is intended behavior. Please see #5159 for the detail.

But I think a user who has no permission to see the issue should not be added as a watcher. This is being discussed in #16133.

Also available in: Atom PDF