Defect #31238

The input field of the Gantt chart page is narrow

Added by Mizuki ISHIKAWA over 2 years ago. Updated over 2 years ago.

Status:ClosedStart date:
Priority:NormalDue date:
Assignee:Go MAEDA% Done:

0%

Category:UI
Target version:-
Resolution:Fixed Affected version:

Description

The input field of the Gantt chart page is narrow.
I think that the cause is that "box-sizing: border-box;" is added to the style of the input field.

Related to #31147.
Affected version: trunk.

ScreenShot_2019-04-22_13.31.47.png (52.8 KB) Mizuki ISHIKAWA, 2019-04-22 06:32


Related issues

Related to Redmine - Patch #31147: Add custom styles for all fields Closed

Associated revisions

Revision 18074
Added by Go MAEDA over 2 years ago

input#months on gantt is too narrow (#31147, #31238).

Patch by Mizuki ISHIKAWA.

History

#1 Updated by Mizuki ISHIKAWA over 2 years ago

The problem is solved if you change it as below.

diff --git a/public/stylesheets/application.css b/public/stylesheets/application.css
index 5890180819..4b2dc5ea5a 100644
--- a/public/stylesheets/application.css
+++ b/public/stylesheets/application.css
@@ -775,7 +775,7 @@ label.no-css {
   width:auto;
 }
 input#time_entry_comments { width: 90%;}
-input#months { width: 30px; }
+input#months { width: 46px; }

 .jstBlock .jstTabs, .jstBlock .wiki-preview { width: 99%; }

#2 Updated by Go MAEDA over 2 years ago

  • Related to Patch #31147: Add custom styles for all fields added

#3 Updated by Go MAEDA over 2 years ago

  • Status changed from New to Closed
  • Assignee set to Go MAEDA
  • Resolution set to Fixed

Committed the patch. Thank you for detecting and fixing the bug.

Also available in: Atom PDF