Defect #31657

Update capybara (~> 3.25.0)

Added by Takenori TAKAKI 19 days ago. Updated 19 days ago.

Status:NewStart date:
Priority:NormalDue date:
Assignee:-% Done:

0%

Category:Gems support
Target version:4.1.0
Resolution: Affected version:

Description

I got the following warning while testing test/system.
This is caused by a version of capybara in Gemfile ('~> 2.13').

$ rake test TEST=test/system
 :
WARN Selenium [DEPRECATION] Selenium::WebDriver::Error::UnhandledError is deprecated. Use Selenium::WebDriver::Error::UnknownError (ensure the driver supports W3C WebDriver specification) instead.
WARN Selenium [DEPRECATION] Selenium::WebDriver::Error::ElementNotVisibleError is deprecated. Use Selenium::WebDriver::Error::ElementNotInteractableError (ensure the driver supports W3C WebDriver specification) instead.
 :

From the above, How about removing Capybara's version?

diff --git a/Gemfile b/Gemfile
index 37449f09f..3a5212e26 100644
--- a/Gemfile
+++ b/Gemfile
@@ -81,7 +81,7 @@ group :test do
   gem "ffi", platforms: [:mingw, :x64_mingw, :mswin]
   # For running system tests
   gem 'puma', '~> 3.7'
-  gem "capybara", '~> 2.13'
+  gem "capybara" 
   gem "selenium-webdriver" 
   # RuboCop
   gem 'rubocop', '~> 0.72.0'

31657.patch Magnifier (880 Bytes) Takenori TAKAKI, 2019-07-02 10:03

History

#1 Updated by Go MAEDA 19 days ago

  • Subject changed from DEPRECATION WARNING: Selenium::WebDriver::Error::***Error is deprecated. to Update capybara (~> 3.25.0)
  • Category set to Gems support
  • Target version set to 4.1.0

Thank you for reporting this issue.

I think it is better to pin the version to the tested one. Unintended update of gems may break test.

diff --git a/Gemfile b/Gemfile
index 37449f09f..9aa6e66f5 100644
--- a/Gemfile
+++ b/Gemfile
@@ -81,7 +81,7 @@ group :test do
   gem "ffi", platforms: [:mingw, :x64_mingw, :mswin]
   # For running system tests
   gem 'puma', '~> 3.7'
-  gem "capybara", '~> 2.13'
+  gem "capybara", '~> 3.25.0'
   gem "selenium-webdriver" 
   # RuboCop
   gem 'rubocop', '~> 0.72.0'

#2 Updated by Takenori TAKAKI 19 days ago

Thank you for your comment Mr. Maeda.

Go MAEDA wrote:

I think it is better to pin the version to the tested one. Unintended update of gems may break test.

I have the same opinion as you.
When I ran the test, I needed to fix the test code.
So I posted the patch again.

Also available in: Atom PDF