Feature #31984

Permission to add timelogs in past

Added by Aleksandar Pavic 6 months ago. Updated 6 months ago.

Status:ClosedStart date:
Priority:NormalDue date:
Assignee:-% Done:

0%

Category:Time tracking
Target version:-
Resolution:Duplicate

Description

There is permission to edit time logs,

But, what's missing is forbid to add time log for date in past.

There are many use-cases where employees log time on daily basis, but should not
be able to log time retro-actively.

Even if they don't have edit timelog permission, they can still log
time for days in past, which should be good to forbid.


Related issues

Duplicates Redmine - Feature #13244: Restrict log time for old days Reopened

History

#1 Updated by Mischa The Evil 6 months ago

#2 Updated by Mischa The Evil 6 months ago

  • Status changed from New to Closed
  • Resolution set to Duplicate

Closing as a duplicate of #13244. I'll see if I am able to look into this issue again in a decent time frame soon.

#3 Updated by Jan K. 6 months ago

Thanks for checking. We have the same problem In our use case. Users should log their time max 1-3 days back butthey do it just to fiil the time. I'd like to restrict it. If they do not log the time properly, they should have a problem which can solve only someone with higher privilegy.

Also available in: Atom PDF