Defect #32422

Textile indentation does not work in the preview tab

Added by Yuichi HARADA 8 months ago. Updated 7 months ago.

Status:ClosedStart date:
Priority:NormalDue date:
Assignee:Go MAEDA% Done:

0%

Category:Text formatting
Target version:4.0.6
Resolution:Fixed Affected version:

Description

I entered the following textile in the issue description field and confirmed to the preview, but I can't show the paragraph indent.

p>. right aligned

p=. centered

p(. left indent 1em

p((. left indent 2em

p>)). right aligned + right indent 2em

p>). right aligned + right indent 1em

- Actual -

actual_not_show_indent.png (57.4 KB) Yuichi HARADA, 2019-11-06 07:29

show_indent.png (57.4 KB) Yuichi HARADA, 2019-11-06 07:40

Associated revisions

Revision 19346
Added by Go MAEDA 7 months ago

Textile indentation does not work in the preview tab (#32422).

Patch by Yuichi HARADA.

Revision 19349
Added by Go MAEDA 7 months ago

Merged r19346 from trunk to 4.1-stable (#32422).

Revision 19350
Added by Go MAEDA 7 months ago

Merged r19346 from trunk to 4.0-stable (#32422).

History

#1 Updated by Yuichi HARADA 8 months ago

Indentation is now visible in the following patch.

diff --git a/public/stylesheets/application.css b/public/stylesheets/application.css
index 2fc541bc0..834dead9d 100644
--- a/public/stylesheets/application.css
+++ b/public/stylesheets/application.css
@@ -827,7 +827,9 @@ input#months { width: 46px; }
 .tabular.settings .wiki-preview, .tabular.settings .jstTabs { width: 99%; }
 .tabular .wiki-preview p {
   min-height: initial;
-  padding: 1em 0 1em 0 !important;
+  padding: 0;
+  padding-top: 1em !important;
+  padding-bottom: 1em !important;
   overflow: initial;
 }

#2 Updated by Go MAEDA 7 months ago

  • Category set to Text formatting
  • Status changed from New to Confirmed
  • Target version set to 4.0.6

Confirmed that the issue is reproduceble and the patch in #32422#note-1 fixes it.

Setting the target version to 4.0.6.

#3 Updated by Go MAEDA 7 months ago

  • Subject changed from Wiki preview: Unable to display indent in preview to Textile indentation does not work in the preview tab
  • Status changed from Confirmed to Resolved
  • Assignee set to Go MAEDA
  • Resolution set to Fixed

Committed the patch. Thank you for catching and fixing the issue.

#4 Updated by Go MAEDA 7 months ago

  • Status changed from Resolved to Closed

Also available in: Atom PDF