Project

General

Profile

Actions

Patch #32922

closed

Reload detached attachments

Added by Pavel Rosický over 4 years ago. Updated about 3 years ago.

Status:
Closed
Priority:
Normal
Assignee:
Category:
Code cleanup/refactoring
Target version:
Start date:
Due date:
% Done:

0%

Estimated time:

Description

use #reload instead, after upgrading to Rails 5


Files

acts_as_attachable.rb.patch (552 Bytes) acts_as_attachable.rb.patch Pavel Rosický, 2020-01-30 00:56

Related issues

Related to Redmine - Feature #29914: Migrate to Rails 6.1 with Zeitwerk autoloadingClosedGo MAEDA

Actions
Actions #1

Updated by Marius BĂLTEANU over 4 years ago

Thanks Pavel for posting the patches for Rails 6 update.

I've applied this patch on the current trunk and a test fails:

 Failure:
 AttachmentsTest#test_upload_and_resubmit_after_validation_failure [/builds/redmine-org/redmine/test/integration/attachments_test.rb:113]:
 Expected at least 1 element matching "input[name="attachments[p0][description]"][value="My uploaded file"]", found 0..
 Expected 0 to be >= 1.
 bin/rails test test/integration/attachments_test.rb:99

You can see the test results here.

Actions #2

Updated by Marius BĂLTEANU over 4 years ago

  • Related to Feature #29914: Migrate to Rails 6.1 with Zeitwerk autoloading added
Actions #3

Updated by Pavel Rosický over 4 years ago

  • Status changed from New to Resolved

sry, thanks for catching this, I was confused about the comment. Closing

Actions #4

Updated by Marius BĂLTEANU over 4 years ago

  • Status changed from Resolved to New

Let's keep it open, maybe we can fix the issue.

Actions #5

Updated by Marius BĂLTEANU about 3 years ago

  • Subject changed from reload detached attachments to Reload detached attachments

This change passes all the tests now: https://gitlab.com/redmine-org/redmine/-/pipelines/280930686

The fail reported by me above was caused by another issue that was fixing as part of Rails 6.1 update.

Actions #6

Updated by Marius BĂLTEANU about 3 years ago

  • Target version set to 5.0.0
Actions #7

Updated by Go MAEDA about 3 years ago

  • Category set to Code cleanup/refactoring
  • Status changed from New to Closed
  • Assignee set to Go MAEDA

Committed the patch. Thank you.

Actions

Also available in: Atom PDF