Feature #35686

Add configured theme and whether it includes JavaScript to Redmine::Info.

Added by Mischa The Evil 3 months ago. Updated 2 months ago.

Status:ClosedStart date:
Priority:NormalDue date:
Assignee:-% Done:

0%

Category:Administration
Target version:-
Resolution:Duplicate

Description

Given that a fair amount of (UI) issues are caused by a third-party theme (see e.g. recently closed #35258 and #35534), it would be really helpful if information about the configured theme and whether it includes JavaScript is added to Redmine::Info.

Example:

I'll leave a patch against current trunk.

0001-Add-current-theme-and-whether-it-includes-JavaScript.patch Magnifier - Patch against trunk @ r21131 (1.28 KB) Mischa The Evil, 2021-08-05 01:45

2021-08-05_01-36-12.png (15 KB) Mischa The Evil, 2021-08-05 01:46


Related issues

Duplicates Redmine - Feature #32116: Add configured theme to Redmine::Info New

History

#1 Updated by Go MAEDA 3 months ago

I am in favor of adding this feature.

I have seen UI troubles caused by third-party themes many times. Showing information about the current theme should make troubleshooting easier.

#2 Updated by Guillermo ML 3 months ago

There is a similar issue: #32116

#3 Updated by Go MAEDA 3 months ago

  • Related to Feature #32116: Add configured theme to Redmine::Info added

#4 Updated by Mischa The Evil 2 months ago

  • Status changed from New to Closed
  • Resolution set to Duplicate

I had totally missed the earlier issue. Thanks for pointing it out.
I've transferred this issue's attachments and text to #32116 and I'll close this issue hereby accordingly.

#5 Updated by Mischa The Evil 2 months ago

  • Related to deleted (Feature #32116: Add configured theme to Redmine::Info)

#6 Updated by Mischa The Evil 2 months ago

  • Duplicates Feature #32116: Add configured theme to Redmine::Info added

Also available in: Atom PDF