Defect #35827

Deleting a closed or archived project returns 403

Added by Holger Just about 1 year ago. Updated about 1 year ago.

Status:ClosedStart date:
Priority:NormalDue date:
Assignee:Marius BALTEANU% Done:

0%

Category:Projects
Target version:4.2.3
Resolution: Affected version:

Description

Following #33945, it turned out that the patch removes the ability to delete closed or archived projects (even for administrators). The behavior is here:

  • deleting an archived project (as admin) - HTTP 403: The project you're trying to access has been archived.
  • deleting a closed project - HTTP 403 - You are not authorized to access this page.

The attached patch fixes this. With this patch, closed projects can be deleted by normal users (if they have the project permission) or administrators. Archived projects can be deleted by admins only. The behavior for active projects is unchanged.

I'm setting the target version to 4.2.3 since this is a regression since Redmine 4.2.0.

0001-Allow-to-delete-closed-and-archived-projects.patch Magnifier (3.91 KB) Holger Just, 2021-08-30 18:52

Associated revisions

Revision 21210
Added by Marius BALTEANU about 1 year ago

Fix that deleting a closed or archived projects not working anymore after r20034 (#35827).

Patch by Holger Just.

Revision 21214
Added by Marius BALTEANU about 1 year ago

Merged r21210 to 4.2-stable (#35827).

Revision 21218
Added by Marius BALTEANU about 1 year ago

Fix Layout/MultilineArrayBraceLayout offense (#21210).

Revision 21221
Added by Marius BALTEANU about 1 year ago

Merged r21218 from trunk to 4.2-stable (#35827).

History

#1 Updated by Marius BALTEANU about 1 year ago

  • Category set to Projects
  • Status changed from New to Resolved
  • Assignee set to Marius BALTEANU

Patch committed, thank you.

#2 Updated by Marius BALTEANU about 1 year ago

  • Status changed from Resolved to Closed

#3 Updated by Marius BALTEANU about 1 year ago

  • Tracker changed from Patch to Defect
  • Subject changed from Allow to delete closed and archived projects to Deleting a closed or archived project returns 403

Also available in: Atom PDF