Defect #36453

Issue subject overflow in subtasks and relations tables

Added by Dmitry Makurin 8 months ago. Updated 4 months ago.

Status:ClosedStart date:
Priority:NormalDue date:
Assignee:Marius BALTEANU% Done:

0%

Category:UI - Responsive
Target version:4.2.7
Resolution:Fixed Affected version:

Description

If issue has a pretty long title it will took all available space in table row.

Here are the screenshots with a problem.
Subtasks:

Relations:

And issue itself:

Found that there're already some styles in responsive.css for this tables. I would like to move it to application.css as default not only for small screens.

Subtasks list after patch:

Issue subject:

ksnip_20220119-181949.png (71.3 KB) Dmitry Makurin , 2022-01-19 16:51

ksnip_20220119-183604.png (48.4 KB) Dmitry Makurin , 2022-01-19 16:51

ksnip_20220119-182523.png (42.7 KB) Dmitry Makurin , 2022-01-19 16:51

ksnip_20220119-181822.png (67.7 KB) Dmitry Makurin , 2022-01-19 16:51

ksnip_20220119-182538.png (58.2 KB) Dmitry Makurin , 2022-01-19 16:51

0001-fix-subject-overflow.patch Magnifier (2.65 KB) Dmitry Makurin , 2022-01-19 16:52


Related issues

Related to Redmine - Defect #37282: Subtask isn't displayed correctly since 4.2.7 Resolved

Associated revisions

Revision 21642
Added by Marius BALTEANU 4 months ago

Fix issue subject overflows in subtasks and relations tables (#36453).

Patch by Dmitry Makurin.

Revision 21648
Added by Marius BALTEANU 4 months ago

Merged r21642 to 5.0-stable (#36453).

Revision 21649
Added by Marius BALTEANU 4 months ago

Merged r21642 to 4.2-stable (#36453).

History

#1 Updated by Marius BALTEANU 7 months ago

  • Category set to UI - Responsive
  • Status changed from New to Confirmed
  • Target version set to Candidate for next minor release

#2 Updated by Marius BALTEANU 7 months ago

  • Assignee set to Marius BALTEANU
  • Target version changed from Candidate for next minor release to 4.1.7

#3 Updated by Marius BALTEANU 6 months ago

  • Target version changed from 4.1.7 to 4.2.6

#4 Updated by Marius BALTEANU 5 months ago

  • Target version changed from 4.2.6 to 4.2.7

#5 Updated by Marius BALTEANU 4 months ago

  • Status changed from Confirmed to Resolved
  • Resolution set to Fixed

Patch committed, thanks!

#6 Updated by Marius BALTEANU 4 months ago

  • Status changed from Resolved to Closed

#7 Updated by Go MAEDA 3 months ago

  • Related to Defect #37282: Subtask isn't displayed correctly since 4.2.7 added

Also available in: Atom PDF