Defect #36592

Import hangs when "related to" issue could not be created

Added by Harald Deischinger 6 months ago. Updated 6 months ago.

Status:ClosedStart date:
Priority:NormalDue date:
Assignee:-% Done:

0%

Category:Importers
Target version:-
Resolution:Duplicate Affected version:4.2.3

Description

When importing issues and specifiny a "related to" relationship, the import hangs when the issue refered could not be imported.

See the attached example:
- Issue ID 3 fails to create (missing Subject)
- Issue ID 4 tries to link to issue ID 3 - here the input hangs.

IssueImport.csv Magnifier (272 Bytes) Harald Deischinger, 2022-02-09 12:05

screenshot.png (13.7 KB) Mizuki ISHIKAWA, 2022-02-10 06:16


Related issues

Duplicates Redmine - Defect #35656: When importing issue relations, the validation messages a... Closed

History

#1 Updated by Mizuki ISHIKAWA 6 months ago

I was able to reproduce the problem in my environment.

If the issue relation fails, the following exception will be raised.

F, [2022-02-10T05:14:06.190123 #5628] FATAL -- :   
ActiveRecord::RecordInvalid (Validation failed: Related issue cannot be blank):

The screen will remain unchanged during the import and you will not be able to notice why it failed.

#2 Updated by Marius BALTEANU 6 months ago

  • Duplicates Defect #35656: When importing issue relations, the validation messages are not shown in the UI added

#3 Updated by Marius BALTEANU 6 months ago

  • Status changed from New to Closed
  • Resolution set to Duplicate

Thanks for reporting this defect!

Closing as duplicate of #35656, please watch that issue for updates.

Also available in: Atom PDF