Project

General

Profile

Actions

Feature #3870

closed

Add "spoiler" or "cut" element to wiki markup

Added by Andrew Chaika almost 15 years ago. Updated over 8 years ago.

Status:
Closed
Priority:
Normal
Assignee:
-
Category:
Wiki
Target version:
-
Start date:
2009-09-15
Due date:
% Done:

0%

Estimated time:
Resolution:
Duplicate

Description

Add ability to insert html element that in default state hide their content.
Syntax may be:

  <spoiler>
  This text is hidden by default
  </spoiler>

This might be useful for example to hide rails logs.


Files

spoiler.htm (2.26 KB) spoiler.htm Andrew Chaika, 2009-10-01 07:44

Related issues

Is duplicate of Redmine - Feature #12167: Macro for inserting collapsible block of textClosedJean-Philippe Lang

Actions
Actions #1

Updated by Eric Davis almost 15 years ago

  • Category set to Wiki

How would this work? Would there be a link to show/hide the hidden content?

Actions #2

Updated by Andrew Chaika almost 15 years ago

Something like this spoiler.htm

Actions #3

Updated by Alexey Ponomarev about 13 years ago

That would be nice to see this feature in one of the further releases.

Actions #4

Updated by Pavel Sokolov over 12 years ago

+1

Actions #6

Updated by Dev Full stack about 10 years ago

+1

Actions #7

Updated by Dev Full stack about 10 years ago

+1

Actions #9

Updated by Sergey Startsev over 8 years ago

Michael Zakharenko wrote:

may be collapse macro helps ?

http://www.redmine.org/projects/redmine/wiki/RedmineTextFormatting#Macros

+1

Actions #10

Updated by Sergey Startsev over 8 years ago

I suggest to close the ticket in cause of macro existence

Actions #11

Updated by Go MAEDA over 8 years ago

  • Status changed from New to Closed
  • Resolution set to Duplicate

As Michael Zakharenko and Sergey Startsev wrote, this can be done with {{collapse}} macro implemented by #12167 (Redmine 2.2). I am closing this issue.

Thanks for pointing it out.

Actions #12

Updated by Go MAEDA over 8 years ago

  • Is duplicate of Feature #12167: Macro for inserting collapsible block of text added
Actions

Also available in: Atom PDF