Defect #4599

PDF Exports with more than 7 columns overflows

Added by Andrew Leaf over 11 years ago. Updated over 8 years ago.

Status:ClosedStart date:2010-01-18
Priority:LowDue date:
Assignee:-% Done:

0%

Category:PDF export
Target version:-
Resolution: Affected version:0.9.0

Description

Environment -

Found in RC1 0.9, Ruby 1.8.6, Rails 2.3.5, Rack 1.0.1, mysql
User language is English.

Summary -

PDF Exports with more than 7 columns (including subject) and a time/date field as the final column, result in am/pm outside the right-most column.

Steps to reproduce -

  1. Install RC 1 of 0.9 from RubyForge
  2. Create several issues
  3. Create a customized column configuration that includes "Subject", 7 or more other fields with either "Created" or "Updated" as the last column
  4. View the issue list
  5. Export the issue list to PDF
  6. View the PDF, observe that AM/PM is outside the bounding box of the right-most column
  7. Modify the issue list so there are fewer columns, or that Created/Updated are not the last column
  8. Export and view the issue list to PDF
  9. Observe this problem no longer exists

I have attached PDFs showing the views with different column configurations.

Note: This did not occur in 0.8.3, but the PDF export view was different then, with fixed columns.

export-8.pdf (1.89 KB) Andrew Leaf, 2010-01-18 01:50

export-9.pdf (1.79 KB) Andrew Leaf, 2010-01-18 01:50

export-10.pdf (1.76 KB) Andrew Leaf, 2010-01-18 01:50

export-11.pdf (1.79 KB) Andrew Leaf, 2010-01-18 01:50

History

#1 Updated by Jean-Philippe Lang over 11 years ago

  • Subject changed from PDF Exports with more than 7 columns (including subject) and a time/date field as the final column, result in am/pm outside the right-most column. to PDF Exports with more than 7 columns overflows
  • Priority changed from Normal to Low

#2 Updated by Etienne Massip over 9 years ago

  • Category changed from Issues to PDF export

#3 Updated by Filou Centrinov over 8 years ago

Candidate to be closed. I can't reproduce this for Redmine 2.3.1. It seems to be fixed, isn't it?

#4 Updated by Toshi MARUYAMA over 8 years ago

  • Status changed from New to Closed

PDF exporting was fully rewritten by #61 1.2.0.

Also available in: Atom PDF