Project

General

Profile

Actions

Feature #6331

closed

Give a role a permission to view/edit only his tickets

Added by Alexander F over 13 years ago. Updated over 8 years ago.

Status:
Closed
Priority:
Normal
Assignee:
-
Category:
Issues permissions
Target version:
-
Start date:
2010-09-08
Due date:
% Done:

0%

Estimated time:
Resolution:
Duplicate

Description

Hi,
Currently in redmine I grant a role only with the option to globally view tickets and globally edit tickets or not at all.
I think it is very important to add a feature that allows users that have a certain role to view and edit only their tickets.

Thanks,
Alexander


Files

Untitled.png (7.16 KB) Untitled.png Bruce Svare, 2013-04-01 21:37

Related issues

Related to Redmine - Feature #5195: edit_own_issues and delete_own_issues permissionsNew2010-03-26

Actions
Is duplicate of Redmine - Feature #7412: Add an issue visibility level to each roleClosed2011-01-22

Actions
Actions #1

Updated by Dmitry Vyal about 13 years ago

It would be very useful feature for us too. What do developers think? Is it feasible to implement it given the current architecture of redmine?

Actions #3

Updated by Dmitry Vyal about 13 years ago

Yeah, quite similar although this one is narrower. I must say, it was not an easy job to follow all that lengthy discussion.

If there is a consensus #337 would be implemented in redmine-1.1, I guess this feature is a duplicate and should be closed.

Actions #4

Updated by Jean-Philippe Lang about 13 years ago

  • Category changed from Permissions and roles to Issues permissions
Actions #5

Updated by pasquale [:dedalus] over 12 years ago

+1

Actions #6

Updated by Bruce Svare almost 11 years ago

Already done?

Actions #7

Updated by Toshi MARUYAMA almost 11 years ago

  • Status changed from New to Needs feedback
  • Priority changed from High to Normal
Actions #8

Updated by Go MAEDA almost 9 years ago

  • Status changed from Needs feedback to Closed
  • Resolution set to Duplicate

Implemented by #7412 as Bruce Svare pointed out.
I close this issue.

Actions #9

Updated by Go MAEDA almost 9 years ago

  • Is duplicate of Feature #7412: Add an issue visibility level to each role added
Actions #10

Updated by Chet Wang almost 9 years ago

I don't think this is OP wanted.
Visibility only control the 'view' permission of issues, but system still lacks another function -- edit permission. Users should edit only their raised tickets, I mean issue properties.

Actions #11

Updated by Toshi MARUYAMA over 8 years ago

Chet Wang wrote:

I don't think this is OP wanted.
Visibility only control the 'view' permission of issues, but system still lacks another function -- edit permission. Users should edit only their raised tickets, I mean issue properties.

I think it is duplicate of #5195.

Actions #12

Updated by Toshi MARUYAMA over 8 years ago

  • Related to Feature #5195: edit_own_issues and delete_own_issues permissions added
Actions

Also available in: Atom PDF