Defect #6568

Custom field min_length and max_length checks and multibyte strings

Added by Vitaliy Ischenko about 10 years ago. Updated about 6 years ago.

Status:ClosedStart date:2010-10-04
Priority:NormalDue date:
Assignee:-% Done:

0%

Category:Custom fields
Target version:-
Resolution:Wont fix Affected version:

Description

If custom field contains multibyte string as a value, CustomValue.validate method will fail if byte length of string is out of range [min_length, max_length].

I've tried to use ActiveSupport::Multibyte::Chars and it fixed my case, but i don't know whether it is a right solution.


Related issues

Duplicated by Redmine - Defect #7490: issue's custom field string length check Closed 2011-01-29

History

#1 Updated by Felix Schäfer about 10 years ago

Could you please give steps to reproduce this problem, i.e. what custom field did you create with what options, and what did you try to put in this custom field?

#2 Updated by Vitaliy Ischenko about 10 years ago

I've created ProjectCustomField

For example:
  1. Name: Test
  2. Format: text
  3. Min length: 5
  4. Max length: 7

no default value, no regex
checkboxes left untouched

Then i've navigated to project settings and entered value 'АБВГДЕЖ'

After submitting - validation error appears: "Test is too long (maximum is 7 characters)"

#4 Updated by Felix Schäfer about 10 years ago

I can confirm this problem, but I think as rails3/ruby1.9 is "around the corner", there's no big motivation for the core redmine to get adapted, though what you propose seems to be the preferred way to solve that. If you want to contribute those fixes back, make sure the existing tests pass and create some new to test the multibyte characters.

#5 Updated by Go MAEDA over 6 years ago

Current Redmine can handle multibyte strings right. This issue can be closed.

#6 Updated by Toshi MARUYAMA about 6 years ago

  • Status changed from New to Closed
  • Resolution set to Wont fix

It depends on Ruby 1.8 or not.
Ruby 1.8 support is dropped on Rails4.

Also available in: Atom PDF