Defect #6714

Gant visualization issue

Added by Jose Javier Sianes Ruiz over 11 years ago. Updated about 11 years ago.

Status:ClosedStart date:2010-10-20
Priority:NormalDue date:
Assignee:-% Done:

0%

Category:Gantt
Target version:-
Resolution:Invalid Affected version:1.0.1

Description

We have an estrange Gant visualization issue. In a project when we request to show gant the visualizacion seems to be correct when only open issues are displayed. But when we select to show all issue, issues with subtask closed and opens apears twice (look at issue number 1335), once showing only closed subtask and other with closed and open subtasks. Could be a bug in gant representation module of Redmine? We are using 1.0.1 stable version of Redmine.

gantt-opens.PNG - Gant showing open issues (75.8 KB) Jose Javier Sianes Ruiz, 2010-10-20 18:30

gantt-all.PNG - Gant showing open and closed issues (89.5 KB) Jose Javier Sianes Ruiz, 2010-10-20 18:30

History

#1 Updated by Jean-Baptiste Barth about 11 years ago

Gantt charts has been completely rewritten for Redmine 1.1.0, which will be released in the end of 2010. It seems parent task to subtasks relations are not displayed anymore in the new implementation, and I cannot reproduce the bug with it.

Other contributors: any idea of what we should do here ?

#2 Updated by Eric Davis about 11 years ago

Jean-Baptiste Barth wrote:

It seems parent task to subtasks relations are not displayed anymore in the new implementation, and I cannot reproduce the bug with it.

Parent/child issues are displayed in the new implementation.

Since 1.1 is only a few months away and since the Gantt was completely rewritten, I think this should be closed as won't fix. Any work put into 1.0.x for Gantts will be thrown away.

#3 Updated by Jean-Baptiste Barth about 11 years ago

Eric Davis wrote:

Parent/child issues are displayed in the new implementation.

Hm, not on my tests 5 mins ago :( I'll try to find why and add an issue if needed.

#4 Updated by Jose Javier Sianes Ruiz about 11 years ago

So, do you recommend me to upgrade version 1.1.0 to solve the problem?

#5 Updated by Jose Javier Sianes Ruiz about 11 years ago

  • Status changed from New to Resolved

Solved in #6763

#6 Updated by Mischa The Evil about 11 years ago

  • Status changed from Resolved to Closed
  • Resolution set to Invalid

Jose Javier Sianes Ruiz wrote:

Solved in #6763

Thanks for the feedback. Though I doubt that it was the solution for #6763 which fixed your issue.

Also available in: Atom PDF