Project

General

Profile

Actions

Feature #8559

closed

Sum columns in reports

Added by Bevan Rudge over 12 years ago. Updated about 8 years ago.

Status:
Closed
Priority:
Normal
Assignee:
-
Category:
Issues
Target version:
-
Start date:
2011-06-07
Due date:
% Done:

0%

Estimated time:
Resolution:

Description

It would be nice if Redmine could operate on all the values in a group/column of an issues report in order to, for example;
  • Show the total estimated time
  • Show the total/average progress/level of effort/priority

It would be nice if this was done for groups (if the report is grouped by) and for all the groups (or the total if there is no grouping for the report).

The attached screenshot shows an example of this. It was created using the attached javascript in a JS console like Firebug.


Files

Estimate_total.jpeg (36.4 KB) Estimate_total.jpeg Bevan Rudge, 2011-06-07 23:37
total-estimate.js (1.17 KB) total-estimate.js Bevan Rudge, 2011-06-07 23:37

Related issues

Related to Redmine - Feature #1561: Totals for estimated/spent time and numeric custom fields on the issue listClosedJean-Philippe Lang2008-07-02

Actions
Related to Redmine - Patch #2268: Patch to show Total Estimated Time at the bottom of each list of issues.Closed2008-12-03

Actions
Related to Redmine - Patch #4776: Totals for Estimated TimeClosed2010-02-09

Actions
Related to Redmine - Feature #6571: Totalise numeric columnsClosed2010-10-05

Actions
Actions #1

Updated by Ruedi Silvestri over 12 years ago

+1 it would even be very valueable if such calculation could also be enabled for custom fields.

Actions #2

Updated by Terence Mill over 12 years ago

+1

Actions #3

Updated by fake plastic tree over 12 years ago

+1 this would make reporting much more powerfull.

Actions #4

Updated by Tony Marschall over 12 years ago

There is a plugin providing this feature: https://github.com/planio/redmine_spent_time_column

Actions #5

Updated by Mischa The Evil over 12 years ago

Tony Marschall wrote:

There is a plugin providing this feature: https://github.com/planio/redmine_spent_time_column

Thanks for pointing this out, Tony. It looks like a useful plugin which will fullfill a lot of requirements looking at the issues at redmine.org (see below). I've did a quick compatibility-test on source:/trunk@7623 and everything seems to work as expected (what I already expected to be honest :).

Regarding this issue: it is actually a duplicate of already multiple issues filed here at redmine.org. I know some out of my mind (euh, without looking it up). For now I'll just add these as issue-relations. I'll see if I can find more "relatives" and if they can be combined into one (or more) generic issues in time... Here we go:

Btw: A quick comparison of the available patches in all these issues against the solution implemented in the above mentioned plugin gives me the "feeling" that the best way to implement such a feature in a (current) stock Redmine is to use this plugin instead of patching the Redmine core yourself.

Actions #6

Updated by Lionel VEILLEPEAU over 12 years ago

It will be better in the trunk, the redmine_spent_time_column plugin doesn't work with the redmine_xls_export plugin.

Actions #7

Updated by Toshi MARUYAMA about 8 years ago

  • Status changed from New to Closed

I think this issue is fixed by #1561.
If you have more request, please create new issue.

Actions

Also available in: Atom PDF